Cisco Details Cross-Site-Scripting, Denial-of-Service Flaws

 
 
By Matt Hines  |  Posted 2006-09-22 Email Print this article Print
 
 
 
 
 
 
 

The networking giant releases updates that aim to close three groups of vulnerabilities in its security and router products, which if left unpatched could leave users open to a range of attacks.

Cisco Systems has addressed three sets of software vulnerabilities in its networking and security products that could leave its customers open to outside attacks including cross-site-scripting and denial-of-service attempts.

The San Jose, Calif.-based firm said in a security bulletin posted to its Web site that a software vulnerability present in its Cisco Guard appliance, which is used to help prevent denial-of-service attacks on corporate Web sites, may allow an outsider to redirect users browsers to a URL hosting cross-site scripting code.

Cisco reported that the flaw is exploitable when the appliance is providing its anti-spoofing services between a browser and a Web server, and that attackers could exploit the problem by sending malicious URLs to users via e-mail or instant messaging systems.
Cisco said that the threat could still be exploited on sites that have been designed to prevent cross-site-scripting, and that users must update their security devices to fix the issue. The company has also posted a temporary workaround to help mitigate effects of the vulnerability.

If successful, exploitation of the vulnerability could result in malicious executable code being planted on an affected users computer.

The Cisco Guard appliance is a denial-of-service protection system through which suspicious traffic is identified with the firms Cisco Detector software and then processed by the device for attack mitigation. The appliance typically plays no role in handling valid site traffic, as it is specifically designed to deal with large volumes of malicious traffic.

When the devices anti-spoofing feature is turned on, all diverted HTTP traffic is inspected and then sent back to a browser responsible for the original Web site request. Using this vulnerability, if the original URL that is requested contains a cross-site-scripting attack, the data sent from the appliance will allow a users browser to execute the malicious code, Cisco said.

In order for such an attack to work, Cisco said that users must be lured to access a URL with specifically formatted, embedded script on a site protected by the appliance. The appliance must also be running in active basic protection mode, and the specially crafted HTTP request must be diverted through and processed by the device.

In a second security warning, Cisco detailed an issue in its IPS (Intrusion Prevention System) software that involves a denial-of-service vulnerability in the products Web administration interface. Click here to read more about Cisco security flaws. The flaw is related to malformed SSL (Secure Socket Layer) packets and a fragmented packet evasion vulnerability, the company said.

According to the security bulletin, the company has made a workaround for the Web administration interface SSL denial of service vulnerability available, but has no workaround for the fragmented packet IPS evasion flaw. However, Cisco has made free software updates, available for affected customers, that claim to address the issues.

The company reported that products affected by the Web administration interface issue include its Cisco IDS 4.1 software prior to version 4.1(5c), its Cisco IPS 5.0 software prior to version 5.0(6p1), and its Cisco IPS 5.1 software prior to version 5.1(2). Products affected by the fragmented packet IPS evasion issue include its Cisco IPS 5.0 software prior to version 5.0(6p2) and its Cisco IPS 5.1 software prior to version 5.1(2).

Cisco said that all of its appliances, router modules, and IPS modules containing those programs are also vulnerable to denial-of-service attacks. The Intrusion Prevention and Detection Systems are a set of network security devices that aim to provide network-based threat prevention services.

Cisco said that if exploited, the loopholes could allow outside attackers using a specially crafted sequence of fragmented IP packets to evade detection by an IPS device, which subsequently may allow systems protected by those products to be secretly compromised.

In a third security warning, the company reported a vulnerability in certain versions of its Cisco IOS software running on its IAD2400 series devices, 1900 Series Mobile Wireless Edge Routers and Cisco VG224 Analog Phone Gateways. Successful exploitation of the vulnerability could result in outsiders taking full control of those devices, according to the security bulletin.

The company has made free software updates available to address the vulnerability, and has also published workarounds to mitigate effects of the flaw.

Check out eWEEK.coms for the latest security news, reviews and analysis. And for insights on security coverage around the Web, take a look at eWEEK.com Security Center Editor Larry Seltzers Weblog.
 
 
 
 
 
 
 
 
 
 
 

Submit a Comment

Loading Comments...
 
Manage your Newsletters: Login   Register My Newsletters























 
 
 
 
 
 
 
 
 
 
 
Thanks for your registration, follow us on our social networks to keep up-to-date
Rocket Fuel