Mozilla Fixes Highly Critical Firefox, Thunderbird Flaws

By Ryan Naraine  |  Posted 2006-06-02 Print this article Print

The open-source group ships patches for more than a dozen vulnerabilities in the Firefox browser and Thunderbird e-mail client and ends support for older browser versions.

Mozillas Firefox browser has been updated to fix 13 security vulnerabilities, five rated critical. The open-source group on June 1 shipped Firefox, a security and stability release to correct flaws that could cause security bypass, cross-site scripting, system access and HTTP response-smuggling attacks. Security alerts aggregator Secunia rates the update as "highly critical" because of the risk of remote code execution exploitation.
According to Mozillas advisory, the most serious flaws occur because of errors in the browser engine that could be exploited to cause a memory corruption. This may allow arbitrary code execution attacks.
Click here to read more about security updates to Mozillas Firefox. Firefox also contains two errors in the way specially crafted HTTP responses are handled. In certain situations, these can be exploited to cause the browser to process a response as two separate responses from different sites. Successful exploitation allows execution of arbitrary HTML and script in a users browser session in the context of an arbitrary site, but requires that the browser be configured to use a proxy or that the malicious site share the same IP address as the targeted site. For advice on how to secure your network and applications, as well as the latest security news, visit Ziff Davis Internets Security IT Hub. Two more errors in the handling of the "View Image" and "Show only this frame" functionalities can be exploited to execute arbitrary HTML and script code in a users browser session, the group warned. In addition, an error caused by an off-by-two array boundary error in the "crypto.signText()" function can be exploited to cause a buffer overflow by passing optional Certificate Authority name arguments. This is the final update from Mozilla for older versions of Firefox. The Foundation is encouraging users to upgrade to Firefox 1.5 to take advantage of the automatic patching utility. After this months security update, Mozilla Firefox 1.0.x versions will no longer get updates. The Foundations Thunderbird e-mail and newsgroup application was also updated to correct a wide range of security bugs. Some of the flaws affecting Firefox also exist in Thunderbird. The new version, Thunderbird, also fixes a hang caused by a double-free in Thunderbird when processing a large VCard with invalid base64 characters in it. "Since an attacker can supply an arbitrary amount of well-formed VCard data before introducing the error we presume this could be exploited to run code of the attackers choosing," Mozilla said in an alert. Successful exploitation of some of the vulnerabilities requires that JavaScript be enabled. JavaScript is not enabled by default in Thunderbird. Check out eWEEK.coms for the latest security news, reviews and analysis. And for insights on security coverage around the Web, take a look at Security Center Editor Larry Seltzers Weblog.

Submit a Comment

Loading Comments...
Manage your Newsletters: Login   Register My Newsletters

Rocket Fuel