Mozilla Expands Plug-in Security Check Beyond Firefox

 
 
By Brian Prince  |  Posted 2010-05-11 Email Print this article Print
 
 
 
 
 
 
 

Mozilla has enhanced its plug-in checker to support other browsers besides Firefox.

Back in September, Mozilla started a program to help its users keep their browser plug-ins up-to-date and secure. At the time, that took the form of a message that would appear warning users they were running an outdated version of Adobe Flash Player.

Now, Mozilla has extended the check to cover Safari 4, Chrome 4 and Opera 10.5.

"We have added support for Internet Explorer 7 and 8 for the most popular plug-ins, as well, but since IE requires specific code to be written for each plug-in it will take us a little longer to get to full coverage," blogged Johnathan Nightingale, Mozilla's director of Firefox development.

Running outdated versions of programs naturally opens users up to attackers looking to exploit software vulnerabilities. Several pieces of research have demonstrated that users are often a step or two behind in the patch cycle.

"These days, over 60 percent of the users we see on the plug-in check page with Adobe's Macromedia Flash plug-in installed are running the most recent version, and the number grows to more than 75 percent if we include the second most recent," Nightingale explained. "That's much higher than the Web as a whole, and there is still a lot of work to do to get that number up, but we're confident that the integrated checks for outdated plug-ins in Firefox 3.6 will improve things even further."

 
 
 
 
del.icio.us | digg.com
 
 
 
 
 
 

Submit a Comment

Loading Comments...

 
 
Manage your Newsletters: Login   Register My Newsletters























 
 
 
 
 
 
 
 
 
 
 
Rocket Fuel