POODLE Flaw Found in Legacy SSL 3.0 Encryption

By Sean Michael Kerner  |  Posted 2014-10-15 Print this article Print
POODLE flaw in SSL 3

A vulnerability in an older Secure Sockets Layer version could enable an attacker to decipher encrypted communications, Google disclosed in a research paper.

POODLE, or Padding Oracle On Downgraded Legacy Encryption, is a newly disclosed vulnerability in the legacy SSL 3.0 protocol that could be exposing users of newer Transport Layer Security (TLS) encryption protocols to risk.  Google disclosed the POODLE vulnerability, also identified as CVE-2014-3566, in a research paper. If exploited, the POODLE flaw could potentially enable an attacker to access and read encrypted communications.

SSL 3.0 is a cryptography protocol that debuted back in 1996 and was co-authored by then Netscape engineer Paul Kocher. SSL 3.0 has long since been superseded by TLS version 1.0, 1.1 and more recently TLS 1.2, which was officially defined in August 2008. While SSL 3.0 is now a legacy protocol, many modern Web browsers and Web servers still support SSL 3.0 as a fallback mechanism.

"Most importantly, nearly all browsers support it and, in order to work around bugs in HTTPS servers, browsers will retry failed connections with older protocol versions, including SSL 3.0," Bodo Moeller of the Google Security Team wrote in a blog post. "Because a network attacker can cause connection failures, they can trigger the use of SSL 3.0 and then exploit this issue."

Google recommends that Web server administrators disable support for SSL 3.0 where possible. When disabling SSL 3.0 is not possible, Google is recommending the use of the TLS Fallback Signaling Cipher Suite Value (TLS_FALLBACK_SCSV) for preventing protocol downgrade attacks.

TLS_FALLBACK_SCSV support has now been added to the open-source OpenSSL cryptographic library that is widely used to enable SSL and TLS on Web servers. OpenSSL was the subject of its own critical flaw earlier this year when the Heartbleed vulnerability was disclosed in April. The TLS_FALLBACK_SCSV patch was submitted to the OpenSSL project by Google's Bodo Moeller.

"If SSL 3.0 is disabled in either the client or in the server, that is completely sufficient to avoid the POODLE attack," Moeller wrote in an OpenSSL mailing list message.

From a Web browser perspective, Google has stated that it is now testing changes in its Chrome Web browser to completely disable SSL 3.0 support. Mozilla has stated its similar intentions and plans to eliminate SSL 3.0 support in the Firefox Web browser, starting with the Firefox 34 release set to debut Nov. 25.

"Today, Firefox uses SSLv3 for only about 0.3 percent of HTTPS connections," Mozilla stated in a blog post. "That's a small percentage, but due to the size of the Web, it still amounts to millions of transactions per day."

Microsoft has also issued an advisory on POODLE, and company officials are not too worried about the immediate impact to its customers. "Microsoft is not aware of attacks that try to use the reported vulnerability at this time," Microsoft's advisory states. "Considering the attack scenario, this vulnerability is not considered high risk to customers."

The newly disclosed POODLE vulnerability is not surprising to Qualys Director of Engineering, Ivan Ristic. Ristic, a well-known SSL/TLS expert, is the founder of SSL Labs, which is now operated by Qualys and provides public analysis of SSL/TLS deployment and usage.

"This new attack exploits the MAC [Message Authentication Code] then-Encrypt CBC (Cipher Block Chaining) construction, which is used in all versions of SSL and TLS," Ristic told eWEEK. "This construction has been the source of several problems in the past, and it's now widely accepted as inherently insecure."

Ristic added that in TLS 1.2, which is the latest version of the protocol, there is support for a technique known as authenticated encryption, which is not vulnerable to this most recent attack.

While Ristic acknowledged that the only safe option to deal with POODLE is to disable SSL 3.0, he noted that's going to be a problem for some sites that have clients that don't support newer versions. In particular, Microsoft's older Internet Explorer 6 (IE 6) browser is limited to supporting SSL 3.

Checking for SSL 3.0

There are a number of ways that server administrators and Web browser users can check today to see if they are using technologies that support SSL 3.0.

Dan Timpson, vice president of technology at Digicert, told eWEEK that his company has updated its DigiCert Certificate Inspector tool to alert any customers using SSL 3.0 so that they can quickly identify the SSL endpoints needing the recommended remediation.

Certificate Inspector is a free tool that provides a "comprehensive overview of an organization's entire SSL/TLS landscape, across internal and external networks," Timpson said.

Browser users can employ the Poodle Test Website to check for SSL 3.0 usage.

Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.



Submit a Comment

Loading Comments...
Manage your Newsletters: Login   Register My Newsletters

Rocket Fuel