Fixes Ferret Out SQL Server Bugs

執筆者
Lisa Vaas
Lisa Vaas
Published: Mar 6, 2003
Updated: Feb 2, 2021
2 minute read
eWeek のコンテンツおよび製品のおすすめは、編集上の独立性を保っています。パートナーへのリンクをクリックすると、当社が報酬を得る場合があります。 詳細を見る

Microsoft Corp. has put out hot fixes for two known bugs in its SQL Server database software.

The first bug is explained in a Microsoft online article entitled “FIX: Cannot Remove Microsoft SQL Server 2000 Desktop Engine After You Upgrade to MSDE 2000 SP2”. According to the article, users who originally used a particular build of MSDE and then upgraded to MSDE 2000 SP2 (Service Pack 2) cannot remove MSDE 2000 from their computers.

The build in question, 8.00.194.01, ships in the MSDE folder on the CD-ROMs of all incarnations of SQL Server 2000: Personal, Evaluation, Developer, Standard and Enterprise. The bug manifests itself when users access the Add/Remove Program applet to remove MSDE 2000. One of two errors result: “The instance name specified is invalid,” or “Fatal error during installation.”

A similar error results from using the SQL Server 2000 Desktop Engine Setup program (Setup.exe) with the uninstall command line option (/x switch). The problem occurs only when upgrading the MSDE RTM (release to manufacturing) build (194.01) directly to SP2. The problem doesnt occur on any other editions of MSDE 2000, according to Microsoft, of Redmond, Wash. Neither does the problem occur if users first upgrade from the RTM version to MSDE 2000 SP1, then upgrade to MSDE 2000 SP2. The problem can be fixed by installing SP3. The article also provides a hot-fix that was available before the company released the latest SQL Server service pack.

The second bug describes a rare condition in which SQL Server gives the error message “2003-02-10 17:02:54.39 ods The Scheduler 2 appears to be hung. PSS 0x5F8B3110, EC 0x5F8B32C0, UMS Context 0x050D07D8.” The Microsoft article “FIX: SQL Server 7.0 Scheduler May Periodically Stop Responding During Large Sort Operation” states that when SQL Server processes a query that includes a large, long-running sort operation, this error message can repeat as frequently as once per minute while the query is running. In some cases, SQL Server might also be slow to respond to other requests.

The article notes that, although Microsoft does support a fix for this problem, it should be applied only to specific machines that are experiencing the scheduler response problem. The hot-fix can be obtained by contacting Microsoft Product Support Services. A complete list of Microsoft Product Support Services phone numbersand information about support costs is on Microsofts Web site.

Latest Security News:
Latest Microsoft News:

Search for more stories by Lisa Vaas.
For more Microsoft scoops, check out Ziff Davis Microsoft Watch.

Lisa Vaas

Lisa Vaas

Content Writer

Lisa Vaas is News Editor/Operations for eWEEK.com and also serves as editor of the Database topic center. She has focused on customer relationship management technology, IT salaries and careers, effects of the H1-B visa on the technology workforce, wireless technology, security, and, most recently, databases and the technologies that touch upon them. Her articles have appeared in eWEEK's print edition, on eWEEK.com, and in the startup IT magazine PC Connection.

eWeek Logo

eWeek has the latest technology news and analysis, buying guides, and product reviews for IT professionals and technology buyers. The site's focus is on innovative solutions and covering in-depth technical content. eWeek stays on the cutting edge of technology news and IT trends through interviews and expert analysis. Gain insight from top innovators and thought leaders in the fields of IT, business, enterprise software, startups, and more.

TechnologyAdvice が所有・運営しています。 © 2026 TechnologyAdvice. 無断転載を禁じます

広告主に関する開示:このサイトに掲載されている製品の一部は、TechnologyAdvice が報酬を受け取っている企業のものです。この報酬は、製品がこのサイトのどこにどのように表示されるか(表示される順序など)に影響する場合があります。TechnologyAdvice は、市場で入手可能なすべての企業やすべての種類の製品を掲載しているわけではありません。