FBI Warns That WordPress Faces Terrorist Attack Risk

By Sean Michael Kerner  |  Posted 2015-04-08 Print this article Print
WordPress vulnerable to attack

The Federal Bureau of Investigation issued an alert on April 7 about the potential danger of Islamic State (ISIS) terrorists abusing vulnerabilities in the open-source WordPress blog and content management system software.

"Researchers continue to identify WordPress content management system (CMS) plug-in vulnerabilities, which could allow malicious actors to take control of an affected system," the FBI warned.

Those plug-in vulnerabilities are being abused by ISIS in order to deface Websites. The FBI notes that the defacements demonstrate low-level hacking sophistication.

The FBI warning was published the same day that security vendor Sucuri published an advisory on a new Cross Site Scripting (XSS) risk in the popular WP-Super-Cache plug-in. The vulnerability could potentially enable an attacker to insert malicious code into a WordPress site. WP-Super-Cache has already fixed the issue in its patched 1.4.4 update.

The challenge for WordPress users, as with users of all other applications, is that of keeping everything up-to-date and fully patched. The challenge of patching for WordPress, however, can be made significantly easier than many other types of applications, thanks to a number of different automated patching capabilities.

For the core WordPress CMS itself, ever since the WordPress 3.7 release debuted in October 2013, security updates are automatically applied to existing systems as they become available. That said, as the FBI correctly notes in its advisory, plug-in vulnerabilities are the area of risk for WordPress. Luckily there is a fix for that, too.

Since December 2014, the WordPress Jetpack add-on provides a service that can enable WordPress users with automatic updating of plug-ins. Jetpack is a plug-in and back-end service provided by Automattic, the lead commercial sponsor behind WordPress. The Jetpack plug-in for WordPress users provides multiple services, including a dashboard for managing multiple WordPress sites.

For those who don't want to use Jetpack, or who need another option, there are multiple WordPress security plug-ins available, including the popular Wordfence security plug-in. Wordfence also helps to protect WordPress sites against unauthorized access, and today announced a new tool for password auditing. Passwords can sometimes be the weakest link on a WordPress site, and with the new Wordfence capability, site administrators can now validate the strength of their site's passwords.

It's important to realize and emphasize that even though WordPress is a favorite target of attackers, WordPress has some of the best security tools available to protect sites as well.

Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.

del.icio.us | digg.com

Submit a Comment

Loading Comments...
Manage your Newsletters: Login   Register My Newsletters

Rocket Fuel