Critical Photoshop Bug Out

 
 
By Lisa Vaas  |  Posted 2007-04-26 Print this article Print
 
 
 
 
 
 
 

A highly critical vulnerability that can allow attackers to hijack a user's system has been reported in Adobe Photoshop.

A Secunia advisory said the vulnerability is caused by an error in the handling of bit map files, such as .BMP, .DIB and .RLE. The handling error can be used to cause a stack-based overflow via a specially crafted bit map file.

No attacks have been detected in the wild that exploit this flaw.

The vulnerability is showing up in Adobe Photoshop CS2 and CS3. Other versions might also turn out to be affected.

Secunia is advising Photoshop users to avoid opening untrusted bit map files to avoid exploitation.

 
 
 
 
del.icio.us | digg.com
 
 
 
 
 
 

Submit a Comment

Loading Comments...
 
 
Manage your Newsletters: Login   Register My Newsletters























 
 
 
 
 
 
 
 
 
 
 
Rocket Fuel