Google Patches 39 Android Vulnerabilities in April Update

 
 
By Sean Michael Kerner  |  Posted 2016-04-05 Print this article Print
 
 
 
 
 
 
 
Android flaws

Google patches yet another flaw in the libstagefright media library, one of the 15 critical vulnerabilities the company fixed in its latest patch update.

Another month and Google is once again patching its libstagefright (Stagefright) media library in Android. Google's April patch update for Android was officially announced on April 4, providing 39 security patches, 15 of which are rated by Google as being critical.

Among the critical patches is CVE-2016-0842, which is a remote code execution vulnerability in Stagefright. Flaws in the Android Stagefright media library were first publicly announced in July 2015 by Zimperium zLabs Vice President of Platform Research and Exploitation Joshua Drake.  In fact, the Stagefright flaw disclosure was the incident that inspired Google in August 2015 to begin a monthly patch update cycle. Somewhat ironically, in nearly every Android monthly update that Google has released, the company has patched one or more Stagefright flaw, including in last month's update.

The libstagefright component is somewhat related to Android's overall Mediaserver component, which is also a big focus in the April update. In the new update, Google has patched the Android Mediaserver for seven remote code execution vulnerabilities (CVE-2016-0835, CVE-2016-0836, CVE-2016-0837, CVE-2016-0838, CVE-2016-0839, CVE-2016-0840 and CVE-2016-084).

"During media file and data processing of a specially crafted file, vulnerabilities in mediaserver could allow an attacker to cause memory corruption and remote code execution as the mediaserver process," Google warns in its advisory.

Beyond the critical Mediaserver patches, Google is patching the much maligned Mediaserver component for a high impact privilege escalation vulnerability identified as CVE-2016-2413. Mediaserver is also being patched for four other high impact vulnerabilities (CVE-2016-2416, CVE-2016-2417, CVE-2016-2418 and CVE-2016-2419) that Google refers to as information disclosure flaws in Android.

Also of note in the April Android update is the CVE-2015-1805 critical flaw that Google first warned about in a March 18Android advisory. CVE-2015-1805 is an upstream Linux kernel flaw that was patched by the Linux kernel in 2015, though the update is only coming to Android now.

As it turns out, Google is just now patching Android for an even older critical flaw (CVE-2014-6060) that dates back to 2014—a remote code execution vulnerability in the DHCPCD component. While the CVE-2014-6060 issue only impacts the Android 4.4 operating system, the related CVE-2016-1503 flaw in DHCPCD impacts Android 4.4, 5, 5.1 and 6.

"A vulnerability in the Dynamic Host Configuration Protocol service could enable an attacker to cause memory corruption, which could lead to remote code execution," Google's advisory states.

One flaw that Google fixed could have enabled an attacker to reset a user's Android device and erase all the data. CVE-2016-2421, rated by Google as having moderate severity, is a vulnerability in the Android setup wizard that an attacker could have potentially abused to bypass factory reset protection and erase all content on a device.

Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.

 
 
 
 
 
 
 
 
 
 
 
 
 

Submit a Comment

Loading Comments...
 
Manage your Newsletters: Login   Register My Newsletters























 
 
 
 
 
 
 
 
 
 
 
Rocket Fuel