Google Patches 55 Android Vulnerabilities in September Update

 
 
By Sean Michael Kerner  |  Posted 2016-09-07 Print this article Print
 
 
 
 
 
 
 
Google Android security

More media server flaws surface as Google splits Android updates into three different patch levels. The update provides patches for 55 vulnerabilities.

Google's September Android security update provides users with patches for 55 vulnerabilities spread across three patch levels. Google first began to split Android updates into two patch levels with the July update, which fixed 108 security vulnerabilities.

The basic idea behind the new three-patch model is to make it easier for handset vendors to deliver the most important patches for a subset of vulnerabilities. Google's own Nexus-branded devices receive the complete patch level, which this month is designated as 2016-09-06, while the other two patch levels are 2016-09-05 and 2016-09-01, providing a subset of patches.

Overall, Google is patching eight critical vulnerabilities in Android, including one in the much-maligned media server component. Android's media server and related libraries have been under scrutiny from security researchers since June 2015, when the first Stagefright flaw was revealed.

To date, Google has patched more than 115 media server-related CVE (Common Vulnerabilities and Exposures) flaws in Android. The new CVE-2016-3862 being fixed in the September Android update is a remote code execution vulnerability that Tim Strazzere, director of mobile research at SentinelOne, discovered.

While Google has patched many media server flaws over the course of the past year, the CVE-2016-3862 is really interesting as it was in a different area than the other vulnerabilities, Strazzere said.

"While it is part of the media framework, it is exposed to the system through a simple Java object, which many developers were using, and as a result were unknowingly exposing themselves to this issue," Strazzere told eWEEK. "Essentially, anyone who was using the ExifInterface object that was loading an image could trigger this vulnerability."

If this vulnerability is exploited, an attacker could break into an applications sandbox, and they also could attack the media server, Strazzere explained. A highly sophisticated attacker could use this to target a specific person or application—or simply try to compromise the entire device, he added.

Strazzere found the CVE-2016-3862 issue through fuzzing techniques and looking at how people have reported vulnerabilities in the past and how they claimed to be looking for them.

"We then tried to see if we could beat some of these other companies, and Google, by fuzzing in different places," Strazzere said. "While the end vulnerability is attributed to a media server issue, it was a section of the code base no one else seemed to be looking at."

While CVE-2016-3862 is the only media server issue in the September update marked critical, it's not the only media server issue that Google is patching this month. In fact, Google is patching six additional media server flaws, including five high-severity denial-of-service vulnerabilities (CVE-2016-3899, CVE-2016-3878, CVE-2016-3879, CVE-2016-3880 and CVE-2016-388) and one information disclosure vulnerability that is marked moderate (CVE-2016-3895).

Of note in the September update, Google is patching two of the so-called Quadrooter flaws that were publicly reported by security firm Check Point at the DefCon security conference in August. The two flaws are CVE-2016-5340, which Google identifies as a critical vulnerability that enables privilege escalation in the kernel shared memory subsystem, and CVE-2016-2059, which is rated by Google as having high severity and is also a privilege-escalation flaw.

"An elevation of privilege vulnerability in the Qualcomm networking component could enable a local malicious application to execute arbitrary code within the context of the kernel," Google warns in its advisory.

There are also three patches in the September updates for issues first patched in the upstream Linux kernel in 2015. CVE-2015-1465 and CVE-2015-5364 are a pair of high-severity DoS vulnerabilities in the kernel networking subsystem, and CVE-2015-8839 is a high-severity DoS vulnerability in the kernel ext4 file system.

Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.

 
 
 
 
 
 
 
 
 
 
 
 
 

Submit a Comment

Loading Comments...
 
Manage your Newsletters: Login   Register My Newsletters























 
 
 
 
 
 
 
 
 
 
 
Rocket Fuel