Popular WordPress Plug-ins Vulnerable to Attack: Checkmarx Research

 
 
By Brian Prince  |  Posted 2013-06-18 Email Print this article Print
 
 
 
 
 
 
 

Research from security vendor Checkmarx revealed that 12 of the top 50 plug-ins for the WordPress platform are susceptible to attacks such as SQL injection and cross-site scripting.

A new study has found that roughly 20 percent of the 50 most popular plug-ins for the WordPress platform are vulnerable to common Web attacks.

According to research from security vendor Checkmarx, that figure represents nearly 8 million downloads of plug-ins vulnerable to issues such as SQL injection, cross-site scripting, cross-site request forgery and path traversal. Additionally, the research revealed that seven out of the top 10 most popular e-commerce plug-ins for WordPress are vulnerable to attacks as well—translating to more than 1.7 million downloads.

The findings, Checkmarx argues, indicate a deeper problem than risky problems. At the root of the issue is a lack of security testing and standards by platform-as-a-service (PaaS) providers when it comes to the apps they distribute, as well as a failure by Web administrators to go the extra mile to ensure the plug-ins are safe.

"First of all, Web admins think that if they are downloading these plug-ins from a reputable source, then there is an assumption that they are receiving a secure plug-in," said Maty Siman, CTO of Checkmarx, in an interview. "In our opinion, that is the biggest factor."

Web administrators also are challenged by scheduling and prioritizing issues, he said, explaining that not everyone knows what to do with the source code once it's scanned and vulnerabilities are found.

"Mitigating these issues is extremely overwhelming to the basic Web admin. It's not a straightforward process," he said.

The first scan conducted by Checkmarx occurred in January 2013, and it revealed that 18 of the top 50 most popular plug-ins had vulnerabilities. A second scan conducted in June 2013 showed the number had been cut to 12.

"As people who work with source code and security, we can't say we were surprised by vulnerabilities," Siman said. "The amount of the vulnerabilities, at a staggering 20 percent of the top 50 plug-ins, were, however, extremely surprising. Especially the e-commerce plug-ins were surprising, because the people who deal with e-commerce you would think would be more concerned with the overall security of their plug-ins."

While every line of code has the potential of introducing a vulnerability, Checkmarx found that there was no correlation between the number of lines of code and the vulnerability level of the plug-ins. On the contrary, some plug-ins included only a few thousand lines of code, but had more vulnerabilities than plug-ins containing tens of thousands of lines of code, according to the company's paper.

According to Checkmarx, administrators for WordPress sites should only download plug-ins from reputable sources—in this case, WordPress.org. In addition, the security of plug-ins should be assessed by scanning it for security issues. Old or unused plug-ins should be removed.

Meanwhile, application platform providers need to enforce a security policy on apps that enter the marketplace and make sure they are only authorizing apps that meet their standards, the firm said.

"The world is shifting towards software distribution platforms," Siman noted in a blog post. "App marketplaces continue to tell us that their platforms are secure, but don't buy into those word games. Only if they start enforcing the security of the apps they distribute, [could we] seriously talk about the security of distribution platforms."

 
 
 
 
 
 
 
 
 
 
 
 
 

Submit a Comment

Loading Comments...
 
Manage your Newsletters: Login   Register My Newsletters























 
 
 
 
 
 
 
 
 
 
 
Rocket Fuel