<!DOCTYPE html>
<html xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://ogp.me/ns/fb#" xmlns:og="http://opengraphprotocol.org/schema/">
  <head>

	<meta name="WT.qs_dlk" content="W4tE8QrIhEMAAG89pGAAAAEg"/>

	<meta name="WT.qs_shmv" content="hv20180525-midler.sf.quinstreet.net"/>

	<meta name="DCS.dcsipa" content="1" />

	<meta name="inject_params" content="WT.qs_dlk=W4tE8QrIhEMAAG89pGAAAAEg&"/>
<script>
                document.cookie = 'inject_params=WT.qs_dlk=W4tE8QrIhEMAAG89pGAAAAEg&; path=/;  domain=eweek.com;';
                document.cookie = 'WMUUID=W4tE8QrIhEMAAG89pGAAAAEg; path=/;  domain=eweek.com;';
            </script>
        
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel='shortcut icon' type='image/x-icon' href='/bundles/eweekbase/images/favicon.ico' />
    
                            
                            
            
    <title>Torvalds Says Developer Community Will Keep Linux, Security, Vibrant</title>

    <meta http-equiv="cleartype" content="on"><meta property="og:locale" content="en_US" /><link rel="canonical" href="http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity"><meta property="og:url" content="http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity" ><meta itemscope itemprop="mainEntityOfPage" itemType="http://schema.org/Article" itemid="http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity"/><meta name="title" content="Torvalds Says Open Source Is the Way to Combat Software Complexity"><meta property="og:title" content="Torvalds Says Open Source Is the Way to Combat Software Complexity"><meta name="twitter:title" content="Torvalds Says Open Source Is the Way to Combat Software Complexity"><meta name="description" content="At the Open Source Summit, Linus Torvalds the creator of Linux talked about the Linux development process, security challenges and why Linux will prosper even after he no longer has a guiding hand on the operating system."><meta property="og:description" content="At the Open Source Summit, Linus Torvalds the creator of Linux talked about the Linux development process, security challenges and why Linux will prosper even after he no longer has a guiding hand on the operating system."><meta property="twitter:description" content="At the Open Source Summit, Linus Torvalds the creator of Linux talked about the Linux development process, security challenges and why Linux will prosper even after he no longer has a guiding hand on..."><meta name="robots" content="index,follow"><meta name="Googlebot-News" content="index,follow"><meta property="twitter:card" content="summary_large_image"><meta property="twitter:image" content="/imagesvr_ez/b2bezp/2018/08/Torvalds-Hohndel-1088x725.jpg?alias=social_image"><meta property="og:image" content="/imagesvr_ez/b2bezp/2018/08/Torvalds-Hohndel-1088x725.jpg?alias=social_image"><meta property="og:image:width" content="300px"><meta property="og:image:height" content="560px"><meta name="twitter:site:id" content="15856164"><meta name="twitter:site" content="eWEEKNews"><meta property="og:type" content="article"><meta property="og:site_name" content="eWEEK"><meta property="article:publisher" content="https://www.facebook.com/eWeekNews/"><meta name="twitter:creator" content="Sean Michael Kerner"><meta property="article:section" content="/enterprise-apps" ><meta name="keywords" content="Open Source Summit, Linux, Linus Torvalds, open source"><meta name="news_keywords" content="Open Source Summit, Linux, Linus Torvalds, open source"><meta property="article:tag" content="Open Source Summit"><meta property="article:tag" content="Linux"><meta property="article:tag" content="Linus Torvalds"><meta property="article:tag" content="open source"><meta property="og:updated_time" content="2018-08-31 17:19:17"><meta property="article:modified_time" content="2018-08-31 17:19:17"><meta itemprop="dateModified" content="2018-08-31 17:19:17"/><meta name="robots" content="noodp"/>
                            
                <link href="/cms/css/d0d0c8a.css" rel="stylesheet" type="text/css">
    
        <link href="/cms/css/834138a.css" rel="stylesheet" type="text/css">
    

    
<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
  <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
<![endif]-->
    <script src="/cms/js/b862975.js"></script>
<script type="text/javascript">
    var cmsSpace;
    cmsSpace = cmsSpace || {};

        
        cmsSpace.currentContentId = 1052907;
    
        
        cmsSpace.locationId = 1527925;
    
        
        cmsSpace.currentTopicId = 47103;
    </script>

<!-- Registration Tracking  -->
    <script src="/cms/js/b707007.js"></script>
<!-- End Registration Tracking  -->

    <script>    
    cmsSpace.newstickerDelay = 3000;
    cmsSpace.currentParentId = 47103;
</script>

            <!-- BEGIN DFP core -->
<script type='text/javascript'>
window.qs={consent:{ready:false,service:{dfp:{dc:false},krux:{dc:false,al:false,tg:false,cd:false,sh:false,re:false},ml:{dc:false}}},dfp:{ready:false},krux:{dn:'',jf:'',dr:'',ir:'',noer:''}};
function gDFPC(e){var n=e+"=";var ca=document.cookie.split(';');for(var i=0;i<ca.length;i++){var c=ca[i].replace(/^\s+|\s+$/g,'');if(c.indexOf(n)==0)return c.substring(n.length,c.length);}return "";}function sDFPC(c,v,e){var d=new Date();d.setMonth(d.getMonth()+e);var exp="expires="+d.toUTCString();document.cookie=c+"="+v+";"+exp+";path=/";}function cDFPC(c){if(gDFPC(c)!="")return 1;return 0;}var mbw=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;var myWTDLK=gDFPC('WMUUID');var mlWTFP="";var myWTtemp=gDFPC('WT_FPC').split(":");for(var i=0;i<myWTtemp.length;i++){if(myWTtemp[i].search("id=")==0){mlWTFP=myWTtemp[i].slice(3);}}var qsDFPSec=(location.protocol==="https:"?"true":"false");
</script>
        <!-- Consent info -->
<script type="text/javascript">
    if (cDFPC('_qscon')) {
        if (typeof window.qs != 'undefined' && window.qs.consent) {
            window.qs.consent.service = JSON.parse(gDFPC('_qscon'));
        }
    }
</script>
<script type='text/javascript'>
var tag_def="";var qs_tags=[];var gpt_tmp=[];function refreshDFPTags(){if(typeof googletag.pubads != 'undefined'){googletag.pubads().refresh();}}function hideQSDiv(e){if(document.getElementById){document.getElementById(e).style.visibility="hidden";document.getElementById(e).innerHTML="";}}var myQSPfm="des";var myDFPPfm="des";var mql=window.matchMedia("(max-width: 767px)");if(mql.matches){myQSPfm="mob";myDFPPfm="mob";}else{mql=window.matchMedia("(min-width: 768px) and (max-width: 991px)");if(mql.matches){myQSPfm="tab-p";myDFPPfm="tab";}else{mql=window.matchMedia("(min-width: 992px) and (max-width: 1239px)");if(mql.matches){myQSPfm="tab-l";myDFPPfm="tab";}else{mql=window.matchMedia("(min-width: 1240px)");if(mql.matches){myQSPfm="des";myDFPPfm="des";}}}}
</script>
<script type='text/javascript'>
    console.log('QS: DFP GPT Code');(function(){var src=(location.protocol==="https:"?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";document.write("<scr"+"ipt src=\""+src+"\"></scr"+"ipt>");})();</script>
<script type='text/javascript'>console.log('QS: DFP Tag Code');function displayDFPTag(tag){console.log('QS: Called displayDFPTag("' + tag + '")');var tag_code="";var this_tag_div_style="";var this_tag_inner_div_style=0;switch (tag){case "p1-oop":case "p3-oop":this_tag_div_style=" style='height:0px;'";this_tag_inner_div_style=1;break;case "p1-imu":case "p2-imu":case "p3-imu":case "ic":case "p1-lb":case "p2-lb":case "p1-ciu":case "p2-ciu":case "sky":case "hp-sponsor-logo":case "rr-sponsor-logo":case "vi-sponsor-logo":case "va-sponsor-logo":case "de-sponsor-logo":case "dt-sponsor-logo":case "pf":case "p2-oop":case "wap":break;default:return "<!-- QS-DFP: Unknown tag '"+tag+"' requested -->";}tag_code="<div id='"+tag+"'"+this_tag_div_style+">\n    <scr"+"ipt type=\"text/javascript\">\n        googletag.display('"+tag+"');\n    </scr"+"ipt>\n</div>\n";if(this_tag_inner_div_style){tag_code += "<style type=\"text/css\">#"+tag+"_ad_container{height:0px;}</style>\n";}return tag_code;}</script>
<!-- END DFP core -->
<!-- BEGIN Evidon Code -->
<script type='text/javascript'>console.log('QS: Evidon Code');(function (id) {
    function append(scriptid, url, async) {
        var d = document, sn = 'script', f = d.getElementsByTagName(sn)[0];
        if (!f) f = d.head;
        var s = d.createElement(sn);
        s.async = true;
        s.id = scriptid;
        s.src = url;
        f.parentNode.insertBefore(s, f);
    }
    function getRootDomain() {
        var parts = window.location.hostname.split('.');
        if (parts.length === 2) rootDomain = parts[0];
        else if (parts.length > 2) {
            // see if the next to last value is a common tld
            var part = parts[parts.length - 2];
            if (part === 'com' || part === 'co') {
                rootDomain = parts[parts.length - 3]; // go back one more
            } else {
                rootDomain = part;
            }
        }
        return rootDomain;
    }

    window.evidon = {};
    window.evidon.id = id;
    var cdn = '//c.evidon.com/', rootDomain = getRootDomain(), noticecdn = cdn + 'sitenotice/';
    append('evidon-notice', noticecdn + 'evidon-sitenotice-tag.js', false);
    append('evidon-location', cdn + 'geo/country.js', true);
    append('evidon-themes', noticecdn + id + '/snthemes.js', true);
    if (rootDomain) append('evidon-settings', noticecdn + id + '/' + rootDomain + '/settings.js', true);

    window.evidon.priorConsentCallback = function () {
        // add the tags which need to wait for prior consent
        // here.  This should be all your advertising tags and
        // probably most of your social and tracking tags.

        // QS globals
        window.qs.consent.ready = true;
    }
    window.evidon.closeCallback = function () {
        // this is executed when a user closes a UI element (banner/barrier) without
        // providing consent.

        // QS globals
        window.qs.consent.ready = true;
    }
    window.evidon.consentWithdrawnCallback = function () {
        // this is exeucted if the user withdraws consent and elects to
        // no longer allow technologies to run on the site.

        // QS globals
        window.qs.consent.ready = true;
    }
    window.evidon.consentDeclinedCallback = function () {
        // this is executed if the user explicitly declines giving consent by
        // using a Decline button

        // QS globals
        window.qs.consent.ready = true; 
    }
})(704);
</script>
<!-- END Evidon Code -->
<meta NAME="DCSext.tax" content="product platform os linux,product servers server operating systems linux server operatting system,product development open source software development,audience purchase stage awareness" />
<meta NAME="DCSext.qse_b2b_tax" content="product platform os linux,product servers server operating systems linux server operatting system,product development open source software development,audience purchase stage awareness" />
<!-- BEGIN Krux -->
<script type='text/javascript'>window.qs.krux.dn=gDFPC('dn'),window.qs.krux.jf=gDFPC('jf'),window.qs.krux.dr=gDFPC('dr'),window.qs.krux.ir=gDFPC('ir'),window.qs.krux.noer=gDFPC('noer');
</script>
<script class='kxint' type='text/javascript'>console.log('QS: Krux Interchange Tag');window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);(function(){function retrieve(n){var k='kx'+''+n,ls=(function(){try{return window.localStorage;}catch(e){return null;}})();if(ls){return ls[k]||'';}else if(navigator.cookieEnabled){var m=document.cookie.match(k+'=([^;]*)');return (m&&unescape(m[1]))||'';}else{return '';}}Krux.user=retrieve('user');Krux.segments=retrieve('segs')?retrieve('segs').split(','):[];})();
</script>
<script class='kxct' data-id='Jd-PsEKi' data-timing='async' data-version='3.0' type='text/javascript'>console.log('QS: Krux Control Tag');window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);(function(){var k=document.createElement('script');k.type='text/javascript';k.async=true;k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/Jd-PsEKi.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);}());
</script>
<script type='text/javascript'>console.log('QS: Krux Data Layer');var kruxDataLayer={"page":{"domain":"www.eweek.com","section":"enterprise-apps","category":"enterprise-apps","keywords":"Open Source Summit,Linux,Linus Torvalds,open source","url_path_1":"http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity"},"user":{"dn":'',"jf":'',"dr":'',"ir":'',"noer":''}};if(typeof window.qs!='undefined'&&window.qs.consent.service.krux.dc&&window.qs.consent.service.krux.al&&window.qs.consent.service.krux.tg&&window.qs.consent.service.krux.cd){if(typeof window.qs.krux.dn!='undefined'&&window.qs.krux.dn!='null'){kruxDataLayer.user.dn=window.qs.krux.dn;}if(typeof window.qs.krux.jf!='undefined'&&window.qs.krux.jf!='null'){kruxDataLayer.user.jf=window.qs.krux.jf;}if(typeof window.qs.krux.dr!='undefined'&&window.qs.krux.dr!='null'){kruxDataLayer.user.dr=window.qs.krux.dr;}if(typeof window.qs.krux.ir!='undefined'&&window.qs.krux.ir!='null'){kruxDataLayer.user.ir=window.qs.krux.ir;}if(typeof window.qs.krux.noer!='undefined'&&window.qs.krux.noer!='null'){kruxDataLayer.user.noer=window.qs.krux.noer;}}</script>
<script type='text/javascript'>console.log('QS: Krux Consent Tag');Krux('consent:set',{dc:window.qs.consent.service.krux.dc,al:window.qs.consent.service.krux.al,tg:window.qs.consent.service.krux.tg,cd:window.qs.consent.service.krux.cd,sh:window.qs.consent.service.krux.sh,re:window.qs.consent.service.krux.re},function(errors,body){if(errors){console.error('SF DMP: '+errors);}else{console.log('SF DMP: Successfully set consent flags.');}});</script>
<!-- END Krux -->
<!-- BEGIN ML -->
<script type='text/javascript'>console.log('QS: ML Tag');if (typeof window.qs != 'undefined' && window.qs.consent.service.ml.dc) {var mlCLID="50428";if(typeof mlCLID!='undefined'){var mlEml=gDFPC('eml');(function(f,i,c){var a=decodeURIComponent,e="",l="",o="||",g=";;",h="split",b="length",j="indexOf",k=0,n="localStorage",m="_ccmdt";f[c]=f[c]||{};function d(q){var p;if(f[n]){return f[n][q]||""}else{p=i.cookie.match(q+"=([^;]*)");return(p&&p[1])||""}}f[c].us={};e=a(d(m))[h](o);k=e[b];if(k>0){while(k--){l=e[k][h]("=");if(l[b]>1){if(l[1][j](g)>-1){f[c].us[l[0]]=l[1][h](g);f[c].us[l[0]].pop()}else{f[c].us[l[0]]=l[1]}}}}})(window,document,"_ml");(function(){_ml=window._ml||{};_ml.eid='50027';_ml.clid=mlCLID;if(typeof mlEml!='undefined'){_ml.em=mlEml;}else{_ml.em='';}_ml.ht='shex';_ml.fp=mlWTFP;_ml.redirect=(location.protocol==='https:'?'https:':'http:')+'//beacon.krxd.net/usermatch.gif?partner=madisonlogic&partner_uid=[PersonID]';_ml.informer={enable:true};var s=document.getElementsByTagName('script')[0],cd=new Date(),mltag=document.createElement('script');mltag.type='text/javascript';mltag.async=true;mltag.src=(location.protocol==='https:'?'https:':'http:')+'//ml314.com/tag.aspx?'+cd.getDate()+cd.getMonth()+cd.getFullYear();s.parentNode.insertBefore(mltag,s);})();}
}</script>
<!-- END ML -->
<!-- BEGIN GA -->
<script type='text/javascript'>console.log('QS: GA Tag');var gaSID="UA-48216600-1";(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[  0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create', gaSID, 'auto');ga('set', 'anonymizeIp', true);ga('send', 'pageview');
</script>
<!-- END GA -->
<!-- BEGIN DFP visibility -->
<script type='text/javascript'>
    console.log('QS: DFP Visibility code');

    googletag.pubads().setTargeting('kw',['Open Source Summit','Linux','Linus Torvalds','open source']);
    googletag.pubads().setTargeting('tax',['product platform os linux','product servers server operating systems linux server operatting system','product development open source software development','audience purchase stage awareness']);
    googletag.pubads().setTargeting('path',['enterprise-apps','torvalds-says-open-source-is-the-way-to-combat-software-complexity']);
    googletag.pubads().setTargeting('articlekey','1052907');
    googletag.pubads().setTargeting('pagetype','article');
    googletag.pubads().setTargeting('securesite',''+qsDFPSec+'');
    googletag.pubads().setTargeting('url',['http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity']);
    googletag.pubads().setTargeting('pfm',''+myDFPPfm+'');
    googletag.pubads().setTargeting('env','prod');
    googletag.pubads().setTargeting('wtdlk',''+myWTDLK+'');
    if(typeof _ml!='undefined'&&_ml.us){if(_ml.us.tp&&_ml.us.tp.length>0){if(typeof window.qs!='undefined'&&window.qs.consent.service.ml.dc){googletag.pubads().setTargeting('mlt',''+_ml.us.tp+'');}}}
    if(typeof window.qs!='undefined'&&window.qs.consent.service.krux.dc&&window.qs.consent.service.krux.al&&window.qs.consent.service.krux.tg&&window.qs.consent.service.krux.cd){
        if(typeof Krux!='undefined'&&Krux.segments&&Krux.user){
            googletag.pubads().setTargeting('ksg',Krux.segments);
            googletag.pubads().setTargeting('kuid',Krux.user);
        }
        if(window.qs.krux.dn!=''&&window.qs.krux.dn!='null'){googletag.pubads().setTargeting('dn',''+window.qs.krux.dn+'');}
        if(window.qs.krux.jf!=''&&window.qs.krux.jf!='null'){googletag.pubads().setTargeting('jf',''+window.qs.krux.jf+'');}
        if(window.qs.krux.dr!=''&&window.qs.krux.dr!='null'){googletag.pubads().setTargeting('dr',''+window.qs.krux.dr+'');}
        if(window.qs.krux.ir!=''&&window.qs.krux.ir!='null'){googletag.pubads().setTargeting('ir',''+window.qs.krux.ir+'');}
        if(window.qs.krux.noer!=''&&window.qs.krux.noer!='null'){googletag.pubads().setTargeting('noer',''+window.qs.krux.noer+'');}
    }
    googletag.defineSlot('/5055/b2b/it/eweek/p1-imu',[[300,50],[300,250],[300,600],[300,1050],[320,50]],'p1-imu').defineSizeMapping(googletag.sizeMapping().addSize([1240,650],[[300,250],[300,600],[300,1050]]).addSize([768,321],[[300,250],[300,600]]).addSize([0,0],[[300,50],[300,250],[320,50]]).build()).addService(googletag.pubads()).setTargeting('pos','top');
    googletag.defineSlot('/5055/b2b/it/eweek/p2-imu',[[300,50],[300,250],[300,600],[320,50]],'p2-imu').defineSizeMapping(googletag.sizeMapping().addSize([768,321],[[300,250],[300,600]]).addSize([0,0],[2,2]).build()).addService(googletag.pubads()).setTargeting('pos','mid');
    googletag.defineSlot('/5055/b2b/it/eweek/p1-lb',[[300,50],[320,50],[728,90],[970,90],[970,250]],'p1-lb').defineSizeMapping(googletag.sizeMapping().addSize([1240,650],[[728,90],[970,90],[970,250]]).addSize([768,321],[728,90]).addSize([0,0],[[300,50],[320,50]]).build()).addService(googletag.pubads()).setTargeting('pos','top');
    googletag.defineSlot('/5055/b2b/it/eweek/p2-lb',[[300,50],[320,50],[728,90]],'p2-lb').defineSizeMapping(googletag.sizeMapping().addSize([768,321],[728,90]).addSize([0,0],[2,2]).build()).addService(googletag.pubads()).setTargeting('pos','low');
    if(mbw>640){googletag.defineOutOfPageSlot('/5055/b2b/it/eweek/p1-oop','p1-oop').addService(googletag.pubads());}
    if(mbw>1460){googletag.defineOutOfPageSlot('/5055/b2b/it/eweek/p2-oop','p2-oop').addService(googletag.pubads());}
    if(myDFPPfm == "des" || (myDFPPfm == "mob" && mbw<640)){googletag.defineOutOfPageSlot('/5055/b2b/it/eweek/p3-oop','p3-oop').addService(googletag.pubads());}
    if (myQSPfm == "tab-p"){googletag.defineSlot('/5055/b2b/it/eweek/pf',[[728,90],[600,50]],'pf').addService(googletag.pubads());}

    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.pubads().enableSyncRendering();
    googletag.disablePublisherConsole();
    if(typeof window.qs!='undefined'&&!window.qs.consent.service.dfp.dc){googletag.pubads().setRequestNonPersonalizedAds(1);}
    googletag.enableServices();
</script>

<script type='text/javascript'>
    var myDFPCustParams="&cust_params="+encodeURIComponent('pfm=' + myDFPPfm);
    myDFPCustParams+=encodeURIComponent('&env=prod');
    myDFPCustParams+=encodeURIComponent('&pagetype=article');
    myDFPCustParams+=encodeURIComponent('&articlekey=1052907');
    myDFPCustParams+=encodeURIComponent('&kw=Open Source Summit,Linux,Linus Torvalds,open source');
    myDFPCustParams+=encodeURIComponent('&tax=product platform os linux,product servers server operating systems linux server operatting system,product development open source software development,audience purchase stage awareness');
    myDFPCustParams+=encodeURIComponent('&path=enterprise-apps,torvalds-says-open-source-is-the-way-to-combat-software-complexity');
    myDFPCustParams+=encodeURIComponent('&url=http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity');
</script>
<!-- END DFP visibility -->
<script type="text/javascript">
    var waitForConsent = timeoutms => new Promise((resolve, reject)=>{
        var checkConsent = () => {
            if (timeoutms && (timeoutms % 1000) == 0)
                console.log('QS: Checking for consent data');
            if (typeof window.qs != 'undefined' && window.qs.consent.ready && typeof window.evidon != 'undefined' && window.evidon.notice) {
                // DFP
                window.qs.consent.service.dfp.dc = window.evidon.notice.consentIsGiven;
                // Salseforce/Krux
                window.qs.consent.service.krux.dc = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.al = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.tg = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.cd = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.sh = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.re = window.evidon.notice.consentIsGiven;
                // ML
                window.qs.consent.service.ml.dc = window.evidon.notice.consentIsGiven;
                
                // Set QS consent cookie
                sDFPC('_qscon', JSON.stringify(window.qs.consent.service), 13);
                
                resolve("QS: Consent data is ready");
            } else if ((timeoutms -= 100) < 0) {
                // DFP
                window.qs.consent.service.dfp.dc = false;
                // Salseforce/Krux
                window.qs.consent.service.krux.dc = false;
                window.qs.consent.service.krux.al = false;
                window.qs.consent.service.krux.tg = false;
                window.qs.consent.service.krux.cd = false;
                window.qs.consent.service.krux.sh = false;
                window.qs.consent.service.krux.re = false;
                // ML
                window.qs.consent.service.ml.dc = false;
                
                // Set QS consent cookie
                sDFPC('_qscon', JSON.stringify(window.qs.consent.service), 13);
                
                reject("QS: Consent data is not ready - moving on");
            } else
                setTimeout(checkConsent, 100);
        }
        setTimeout(checkConsent, 100);
    });

    (async ()=>{
        waitForConsent(5000)
            .then(function (msg) {
                console.log(msg);
            })
            .catch(function (err) {
                console.log(err);
            })
    })();
</script>


        
              

    <script>
    window.webtrendsAsyncInit=function(){
        var dcs=new Webtrends.dcs().init({
            dcsid:"dcs0hqs4610000ou3mn7tu0uc_5l6j",
            domain:"www.qsstats.com",
            timezone:-8,
            i18n:true,
            onsitedoms:"eweek.com",
            fpcdom:".eweek.com",
            plugins:{
                //hm:{src:"//s.webtrends.com/js/webtrends.hm.js"}
            }
            }).track();
    };
    (function(){
        var s=document.createElement("script"); s.async=true; s.src="/imageserver/common/v10/webtrends.min.js";    
        var s2=document.getElementsByTagName("script")[0]; s2.parentNode.insertBefore(s,s2);
    }());
    </script>
    <noscript><img alt="dcsimg" id="dcsimg" width="1" height="1" src="//www.qsstats.com/dcs0hqs4610000ou3mn7tu0uc_5l6j/njs.gif?dcsuri=/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity&dcsipa=1&amp;WT.js=No&amp;WT.tv=10.4.1&amp;dcssip=www.eweek.com&amp;WT.qs_dlk=W4tE8QrIhEMAAG89pGAAAAEg&"/></noscript>
</head>
  <body class="">
    <header class="header visible-lg-block">
        <div class="container">
            <div class="eweek-logo" itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
                    <a href="/" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                        <img src="/bundles/eweekbase/images/logo_eweek.jpg" alt="eWEEK - Enterprise IT Technology News, Opinion and Reviews">
                        <meta itemprop="url" content="/bundles/eweekbase/images/logo_eweek.jpg">
                        <meta itemprop="width" content="157"/>
                        <meta itemprop="height" content="42"/>
                    </a>
                    <meta itemprop="name" content="eWEEK">
            </div>
            <nav class="topbar">
                <ul class="user-actions nav navbar-nav pull-right">
                        <li class="hidden no-qs-cookie"><a href="/myeweek/register">Register</a></li>
                        <li class="hidden no-qs-cookie"><a href="#" onclick="showGFrame('login', 'full');return false;">Login</a></li>
                        <li class="hidden email-only-cookie ty-for-subscribing dropdown">
                            <img id="email-only-userimage" class="user-image user-image-top" src="/bundles/qsgigya/images/avatar_48x48.gif" alt="eWEEK Account Options">
                            <a href="#" id="email-only-username" class="user-name user-name-top"></a>
                            <ul class="dropdown-menu">
                                <li><a href="/myeweek/register">Complete My Registration</a></li>
                                <li><a href="#" onclick="onLogoutHandler();return false;">Log out</a></li>
                            </ul>
                        </li>
                        <li class="hidden biz-card-cookie dropdown">
                            <img id="biz-card-userimage" class="user-image user-image-top" src="/bundles/qsgigya/images/avatar_48x48.gif" alt="eWEEK Account Options">
                            <a href="#" id="biz-card-username" class="user-name user-name-top"></a>
                            <ul class="dropdown-menu">
                                <li><a href="/myeweek/register">Complete My Registration</a></li>
                            </ul>
                        </li>
                        <li class="hidden social-user-cookie dropdown">
                            <img id="social-userimage" class="user-image user-image-top" src="/bundles/qsgigya/images/avatar_48x48.gif" alt="eWEEK Account Options">
                            <a href="#" id="social-username" class="user-name user-name-top"></a>
                            <ul class="dropdown-menu">
                                <li><a href="/myeweek/register">Complete My Registration</a></li>
                                <li><a href="#" onclick="EweekLogout();return false;">Log out</a></li>
                            </ul>
                        </li>
                        <li class="hidden light-user-cookie dropdown">
                            <img id="userimage" class="user-image user-image-top" src="/bundles/qsgigya/images/avatar_48x48.gif" alt="eWEEK Account Options">
                            <a href="#" id="username" class="user-name user-name-top"></a>
                            <ul class="dropdown-menu">
                                <li><a href="/myeweek/information">My Account</a></li>
                                <li><a href="/myeweek/subscriptions">My Subscriptions</a></li>
                                <li><a href="#" onclick="EweekLogout();return false;">Log out</a></li>
                            </ul>
                        </li>
                        <li class="hidden full-user-cookie dropdown">
                            <img id="full-userimage" class="user-image user-image-top" src="/bundles/qsgigya/images/avatar_48x48.gif" alt="eWEEK Account Options">
                            <a href="#" id="full-username" class="user-name user-name-top"></a>
                            <ul class="dropdown-menu">
                                <li><a href="/myeweek/information">My Account</a></li>
                                <li><a href="/myeweek/subscriptions">My Subscriptions</a></li>
                                <li><a href="#" onclick="EweekLogout();return false;">Log out</a></li>
                            </ul>
                        </li>
                    <li><a href="/rss.xml" target="_blank"><img src="/bundles/eweekbase/images/social_rss_header.jpg" alt="eWEEK RSS feed"></a></li>
                </ul>
                                
<!-- Main Menu -->
<ul class="nav navbar-nav header-menu pull-right">
                                        <li
            id="menu_82"
             data-related-id="51109"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/big-data-and-analytics"
                            >
                Big Data and Analytics
            </a>
                            <div class="dropdown-menu">
<div class="container">
        <div class="row no-subtopics">
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/big-data-and-analytics/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Walmart.ecommerce.jpg?alias=fatmenu_thumbnail" alt="Walmart.labs" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/big-data-and-analytics/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                IT Science Case Study: How Walmart Embraced Test Automation,...                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-4">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/big-data-and-analytics/it-science-case-study-australian-gas-light-gets-its-act-together">
                                        IT Science Case Study: Australian Gas Light Gets Its...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/big-data-and-analytics/equinix-data-centers-services-product-overview-and-analysis">
                                        Equinix Data Centers, Services: Product Overview and...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/big-data-and-analytics/how-multi-sided-digital-platforms-are-changing-the-rules-in-it">
                                        How Multi-Sided Digital Platforms Are Changing the...                                    </a>
                                </li>
                                                                    </ul></div><div class="col-sm-4"><ul class="latest">
                                                                                            <li>
                                    <a href="http://www.eweek.com/big-data-and-analytics/scylladb-product-overview-and-insight">
                                        ScyllaDB: Product Overview and Insight                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/big-data-and-analytics/devo-survey-highlights-time-cost-benefits-of-centralized-data-systems">
                                        Devo Survey Highlights Time, Cost Benefits of Centralized...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/big-data-and-analytics/how-california-s-new-consumer-privacy-act-stands-to-impact-business">
                                        How California’s New Consumer Privacy Act Stands to...                                    </a>
                                </li>
                                                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_95"
             data-related-id="47113"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/cloud"
                            >
                Cloud
            </a>
                            <div class="dropdown-menu">
<div class="container">
        <div class="row no-subtopics">
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/cloud/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Walmart.ecommerce.jpg?alias=fatmenu_thumbnail" alt="Walmart.labs" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/cloud/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                IT Science Case Study: How Walmart Embraced Test Automation,...                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-4">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/cloud/vmware-vcloud-director-ready-to-run-in-ibm-hybrid-cloud">
                                        VMware vCloud Director Ready to Run in IBM Hybrid Cloud                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/cloud/openstack-rocky-boosts-cloud-deployment-on-bare-metal">
                                        OpenStack Rocky Boosts Cloud Deployment on Bare Metal                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/cloud/vmware-moves-beyond-legacy-systems-to-center-of-multi-cloud-world">
                                        VMware Moves Beyond Legacy Systems to Center of Multi-Cloud...                                    </a>
                                </li>
                                                                    </ul></div><div class="col-sm-4"><ul class="latest">
                                                                                            <li>
                                    <a href="http://www.eweek.com/cloud/new-box-activity-stream-links-to-slack-salesforce-docusign-cloud-apps">
                                        New Box Activity Stream Links to Slack, Salesforce,...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/cloud/box-google-collaboration-tools-rapidly-becoming-interchangeable">
                                        Box, Google Collaboration Tools Rapidly Becoming Interchangeable                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/cloud/kubernetes-development-infrastructure-moving-out-of-google-control">
                                        Kubernetes Development Infrastructure Moving Out of...                                    </a>
                                </li>
                                                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_96"
             data-related-id="47091"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/mobile"
                            >
                Mobile
            </a>
                            
<div class="dropdown-menu">
    <div class="container">
        <div class="row subtopics">
            <div class="col-sm-3">
                                    <ul class="categories">
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/apple">
                                    Apple
                                </a>
                            </li>
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/blogs/upfront">
                                    Upfront Blog
                                </a>
                            </li>
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/android">
                                    Android
                                </a>
                            </li>
                                            </ul>
                            </div>
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/mobile/opposition-seems-muted-in-statements-to-fcc-on-t-mobile-sprint-merger">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2017/11/sprint_t-mobile.png?alias=fatmenu_thumbnail" alt="Sprint T-Mobile" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/mobile/opposition-seems-muted-in-statements-to-fcc-on-t-mobile-sprint-merger">
                                Opposition Seems Muted in Statements to FCC on T-Mobile-Sprint...                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-5">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/mobile/new-ai-driven-find-tab-helps-sharepoint-users-locate-information">
                                        New AI-Driven Find Tab Helps SharePoint Users Locate...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/mobile/blackberry-cuts-features-lowers-key2-le-handset-price-to-lure-buyers">
                                        BlackBerry Cuts Features, Lowers KEY2 LE Handset Price...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/mobile/apple-expected-to-give-mac-mini-ipad-pro-much-needed-upgrades">
                                        Apple Expected to Give Mac Mini, iPad Pro Much Needed...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/mobile/samsung-launches-its-flagship-galaxy-note-9-phablet">
                                        Samsung Launches Its Flagship Galaxy Note 9 Phablet                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/mobile/cypress-semiconductor-product-overview-and-analysis">
                                        Cypress Semiconductor: Product Overview and Analysis                                    </a>
                                </li>
                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_97"
             data-related-id="47087"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/networking"
                            >
                Networking
            </a>
                            <div class="dropdown-menu">
<div class="container">
        <div class="row no-subtopics">
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/networking/cisco-meraki-talari-expand-reach-of-sd-wan-offerings">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/1088x725sdn3.jpg?alias=fatmenu_thumbnail" alt="SDN" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/networking/cisco-meraki-talari-expand-reach-of-sd-wan-offerings">
                                Cisco Meraki, Talari Expand Reach of SD-WAN Offerings                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-4">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/networking/qualcomm-netgear-team-for-mesh-wi-fi-smart-speaker">
                                        Qualcomm, Netgear Team for Mesh Wi-FI Smart Speaker                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/networking/pivot3-unveils-hyperconverged-infrastructure-for-the-rugged-edge">
                                        Pivot3 Unveils Hyperconverged Infrastructure for the...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/networking/aws-launches-over-the-air-updates-for-iot-backbone-freertos">
                                        AWS Launches Over the Air Updates for IoT Backbone...                                    </a>
                                </li>
                                                                    </ul></div><div class="col-sm-4"><ul class="latest">
                                                                                            <li>
                                    <a href="http://www.eweek.com/networking/it-science-case-study-australian-gas-light-gets-its-act-together">
                                        IT Science Case Study: Australian Gas Light Gets Its...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/networking/how-multi-sided-digital-platforms-are-changing-the-rules-in-it">
                                        How Multi-Sided Digital Platforms Are Changing the...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/networking/dell-emc-rolls-out-modular-poweredge-mx-server">
                                        Dell EMC Rolls Out Modular PowerEdge MX Server                                    </a>
                                </li>
                                                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_98"
             data-related-id="47101"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/security"
                            >
                Security
            </a>
                            
<div class="dropdown-menu">
    <div class="container">
        <div class="row subtopics">
            <div class="col-sm-3">
                                    <ul class="categories">
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/blogs/security-watch">
                                    Security Watch Blog
                                </a>
                            </li>
                                            </ul>
                            </div>
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/security/trend-micro-reports-nearly-10-fold-increase-in-cryptojacking-attacks">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/TechBriefing831.jpg?alias=fatmenu_thumbnail" alt="Daily Video 831" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/security/trend-micro-reports-nearly-10-fold-increase-in-cryptojacking-attacks">
                                Trend Micro Reports Nearly 10 Fold Increase in Cryptojacking...                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-5">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/security/the-linux-foundation-set-to-improve-open-source-code-security">
                                        The Linux Foundation Set to Improve Open-Source Code...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/security/what-developers-can-do-to-improve-cyber-security">
                                        What Developers Can Do to Improve Cyber-Security                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/security/linux-kernel-developer-criticizes-intel-for-meltdown-spectre-response">
                                        Linux Kernel Developer Criticizes Intel for Meltdown,...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/security/researchers-discover-computer-screens-emit-sounds-that-reveal-data">
                                        Researchers Discover Computer Screens Emit Sounds that...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/security/how-canonical-is-improving-ubuntu-linux-security">
                                        How Canonical Is Improving Ubuntu Linux Security                                    </a>
                                </li>
                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_99"
             data-related-id="47121"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/servers"
                            >
                Servers
            </a>
                            <div class="dropdown-menu">
<div class="container">
        <div class="row no-subtopics">
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/servers/dell-emc-s-poweredge-mx-server-adapts-to-changes-in-compute-landscape">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/eweek_8.24.18.jpg?alias=fatmenu_thumbnail" alt="Daily Tech Briefing Aug. 24, 2018" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/servers/dell-emc-s-poweredge-mx-server-adapts-to-changes-in-compute-landscape">
                                Dell EMC&#039;s PowerEdge MX Server Adapts to Changes in...                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-4">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/servers/equinix-data-centers-services-product-overview-and-analysis">
                                        Equinix Data Centers, Services: Product Overview and...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/servers/dell-emc-rolls-out-modular-poweredge-mx-server">
                                        Dell EMC Rolls Out Modular PowerEdge MX Server                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/servers/new-nvidia-quadro-gpus-speed-real-time-simulations-video-rendering">
                                        New Nvidia Quadro GPUs Speed Real-Time Simulations,...                                    </a>
                                </li>
                                                                    </ul></div><div class="col-sm-4"><ul class="latest">
                                                                                            <li>
                                    <a href="http://www.eweek.com/servers/dell-emc-targets-ai-workloads-with-integrated-systems">
                                        Dell EMC Targets AI Workloads With Integrated Systems                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/servers/intel-product-roadmap-shows-10nm-xeon-server-chips-arriving-in-2020">
                                        Intel Product Roadmap Shows 10nm Xeon Server Chips...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/servers/microsoft-windows-admin-center-server-updates-add-support-for-azure">
                                        Microsoft Windows Admin Center Server Updates Add Support...                                    </a>
                                </li>
                                                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_100"
             data-related-id="47117"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/storage"
                            >
                Storage
            </a>
                            
<div class="dropdown-menu">
    <div class="container">
        <div class="row subtopics">
            <div class="col-sm-3">
                                    <ul class="categories">
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/blogs/storage-station">
                                    Storage Station Blog
                                </a>
                            </li>
                                            </ul>
                            </div>
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/storage/micron-picks-manassas-va-as-site-for-high-speed-memory-chip-factory">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/1088Micron3DNANDUFS.jpg?alias=fatmenu_thumbnail" alt="Micron NAND Chip Plant in Virginia" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/storage/micron-picks-manassas-va-as-site-for-high-speed-memory-chip-factory">
                                Micron Picks Manassas, VA as Site for High Speed Memory...                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-5">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/storage/vmware-vcloud-director-ready-to-run-in-ibm-hybrid-cloud">
                                        VMware vCloud Director Ready to Run in IBM Hybrid Cloud                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/storage/box-google-collaboration-tools-rapidly-becoming-interchangeable">
                                        Box, Google Collaboration Tools Rapidly Becoming Interchangeable                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/storage/asigra-ixsystems-unveil-new-gen-backup-appliance-at-vmworld">
                                        Asigra, iXsystems Unveil New-Gen Backup Appliance at...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/storage/equinix-data-centers-services-product-overview-and-analysis">
                                        Equinix Data Centers, Services: Product Overview and...                                    </a>
                                </li>
                                                            <li>
                                    <a href="http://www.eweek.com/storage/esf-survey-shows-cloud-hdds-still-dominate-it-storage">
                                        ESF Survey Shows Cloud, HDDs Still Dominate IT Storage                                    </a>
                                </li>
                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_101"
             data-related-id="47115"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/virtualization"
                            >
                Virtualization
            </a>
                            <div class="dropdown-menu">
<div class="container">
        <div class="row no-subtopics">
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/virtualization/maxta-red-hat-intel-team-up-for-hyperconverged-un-appliance">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2017/09/Maxta.logo.JPG?alias=fatmenu_thumbnail" alt="Maxta.logo" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/virtualization/maxta-red-hat-intel-team-up-for-hyperconverged-un-appliance">
                                Maxta, Red Hat, Intel Team Up for Hyperconverged &#039;(Un)Appliance&#039;                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-4">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/virtualization/nutanix-hyperconverged-infrastructure-product-overview-analysis">
                                        Nutanix Hyperconverged Infrastructure: Product Overview,...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/virtualization/managed-istio-service-mesh-now-available-on-google-cloud-platform">
                                        Managed Istio Service Mesh Now Available on Google...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/virtualization/five-security-defenses-every-containerized-application-needs">
                                        Five Security Defenses Every Containerized Application...                                    </a>
                                </li>
                                                                    </ul></div><div class="col-sm-4"><ul class="latest">
                                                                                            <li>
                                    <a href="http://www.eweek.com/virtualization/it-science-case-study-becoming-unconstrained-by-physical-workstations">
                                        IT Science Case Study: Becoming Unconstrained by Physical...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/virtualization/vmware-grows-kubernetes-options-with-vke-pks-services">
                                        VMware Grows Kubernetes Options With VKE, PKS Services                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/virtualization/kubernetes-1.11-improves-cloud-native-application-deployment-options">
                                        Kubernetes 1.11 Improves Cloud-Native Application Deployment...                                    </a>
                                </li>
                                                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_102"
             data-related-id="47105"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/innovation"
                            >
                Innovation
            </a>
                            <div class="dropdown-menu">
<div class="container">
        <div class="row no-subtopics">
                            <div class="col-sm-4">
                    <div class="highlight">
                        <div class="attribute-image">
                                                            <a href="http://www.eweek.com/innovation/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Walmart.ecommerce.jpg?alias=fatmenu_thumbnail" alt="Walmart.labs" />
                                </a>
                                                    </div>
                        <div class="attribute-title">
                            <a href="http://www.eweek.com/innovation/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                IT Science Case Study: How Walmart Embraced Test Automation,...                            </a>
                        </div>
                    </div>
                </div>
                                    <div class="col-sm-4">
                        <ul class="latest">
                                                            <li>
                                    <a href="http://www.eweek.com/innovation/box-google-collaboration-tools-rapidly-becoming-interchangeable">
                                        Box, Google Collaboration Tools Rapidly Becoming Interchangeable                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/innovation/it-science-use-case-carfax-simplifies-development-team-s-workflow">
                                        IT Science Use Case: CarFax Simplifies Development...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/innovation/cypress-semiconductor-product-overview-and-analysis">
                                        Cypress Semiconductor: Product Overview and Analysis                                    </a>
                                </li>
                                                                    </ul></div><div class="col-sm-4"><ul class="latest">
                                                                                            <li>
                                    <a href="http://www.eweek.com/innovation/it-science-case-study-australian-gas-light-gets-its-act-together">
                                        IT Science Case Study: Australian Gas Light Gets Its...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/innovation/what-enterprises-need-to-know-about-new-gen-collaboration-it">
                                        What Enterprises Need to Know About New-Gen Collaboration...                                    </a>
                                </li>
                                                                                            <li>
                                    <a href="http://www.eweek.com/innovation/how-an-enterprise-can-create-a-lasting-culture-of-innovation">
                                        How an Enterprise Can Create a Lasting Culture of Innovation                                    </a>
                                </li>
                                                                                    </ul>
                    </div>
                                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_103"
                        class="dropdown no-link"
        >
            <a
                href="#"
                 class="dropdown-arrow"            >
                More
            </a>
                            <div class="dropdown-menu">
    <ul>
                                                            <li
                id="menu_104"
                 data-related-id="47103"            >
                <a href="http://www.eweek.com/enterprise-apps">
                    Enterprise Apps                </a>
            </li>
                                                            <li
                id="menu_105"
                 data-related-id="47089"            >
                <a href="http://www.eweek.com/android">
                    Android                </a>
            </li>
                                                            <li
                id="menu_106"
                 data-related-id="47099"            >
                <a href="http://www.eweek.com/apple">
                    Apple                </a>
            </li>
                                                            <li
                id="menu_107"
                 data-related-id="47119"            >
                <a href="http://www.eweek.com/it-management">
                    IT Management                </a>
            </li>
                                                            <li
                id="menu_108"
                 data-related-id="47125"            >
                <a href="http://www.eweek.com/small-business">
                    Small Business                </a>
            </li>
                                                            <li
                id="menu_109"
                 data-related-id="47107"            >
                <a href="http://www.eweek.com/development">
                    Development                </a>
            </li>
                                                            <li
                id="menu_110"
                 data-related-id="47111"            >
                <a href="http://www.eweek.com/pc-hardware">
                    PC Hardware                </a>
            </li>
                                                            <li
                id="menu_112"
                 data-related-id="47129"            >
                <a href="http://www.eweek.com/database">
                    Database                </a>
            </li>
                                                            <li
                id="menu_47043"
                 data-related-id="47127"            >
                <a href="http://www.eweek.com/search-engines">
                    Search Engines                </a>
            </li>
            </ul>
</div>
                    </li>
    </ul>
<!-- /Main Menu -->

                            </nav>
        </div>
    </header>
    <div id="main-menu" class="main-menu">
        <div class="container">
                        
<!-- Main Menu -->

<nav class="navbar navbar-default" role="navigation" id="site-top-menu-mobile">
        <div class="navbar-header hidden-lg">
        <button type="button" class="navbar-toggle pull-left" data-toggle="collapse" data-target=".main-menu-collapse" alt="Menu">
            <span class="sr-only">Toggle navigation</span>
            <span class="icon-bar"></span>
            <span class="icon-bar"></span>
            <span class="icon-bar"></span>
        </button>
        <button type="button" class="search-toggle pull-right" data-toggle="collapse" data-target=".search-form-collapse">
            <span class="sr-only">Toggle search</span>
        </button><!-- /.search-toggle -->
        <button type="button" class="login-toggle pull-right" data-toggle="collapse" data-target=".login-form-collapse">
            <span class="sr-only">Toggle login</span>
        </button><!-- /.login-toggle -->
        <div class="eweek-logo">
            <a href="/" itemprop="url"><img src="/bundles/eweekbase/images/logo_eweek.jpg" alt="eWeek - Enterprise IT Technology News, Opinion and Reviews"></a>
        </div><!-- /.eweek-logo -->
    </div><!-- /.navbar-header -->
    <div class="search-form collapse navbar-collapse search-form-collapse">
        <form action="/googlecse" id="cse-search-box" name="cse-search-box" onsubmit="return checkSearchValue();">
            <input type="hidden" name="cx" value="partner-pub-8768004398756183:8606422690" />
            <input type="hidden" name="cof" value="FORID:11" />
            <input type="hidden" name="ie" value="ISO-8859-1" />
            <input  id="searchField" name="q" class="form-control search-query" type="text" value="" />
			<input class="search-submit" type="submit" value="" alt="Search eWeek site">
            <script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=">
</script>
        </form>
    </div>
    <div class="login-form collapse login-form-collapse hidden-lg">
        <ul class="hidden no-qs-cookie nav navbar-nav">
            <li><a href="/myeweek/register">Register</a></li>
            <li><a href="#" onclick="showGFrame('login', 'full');return false;">Login</a></li>
        </ul>
        <ul class="hidden email-only-cookie nav navbar-nav">
            <li><a href="#" class="user-name">Username</a></li>
            <li><a href="/myeweek/register">Complete My Registration</a></li>
            <li><a href="#" onclick="onLogoutHandler();return false;">Log out</a></li>
        </ul>
        <ul class="hidden biz-card-cookie nav navbar-nav">
            <li><a href="#" class="user-name">Username</a></li>
            <li><a href="/myeweek/register">Complete My Registration</a></li>
        </ul>
        <ul class="hidden social-user-cookie nav navbar-nav">
            <li><a href="#" class="user-name">Username</a></li>
            <li><a href="/myeweek/register">Complete My Registration</a></li>
            <li><a href="#" onclick="EweekLogout();return false;">Log out</a></li>
        </ul>
        <div class="hidden light-user-cookie">
            <h3 class="user-cookie-menu-header">
                Username
            </h3>
            <ul class="nav navbar-nav">
                <li><a href="/myeweek/information">My Account</a></li>
                <li><a href="/myeweek/subscriptions">My Subscriptions</a></li>
                <li><a href="#" onclick="EweekLogout();return false;">Log out</a></li>
            </ul>
        </div>
        <div class="hidden full-user-cookie">
            <h3 class="user-cookie-menu-header">
                Username
            </h3>
            <ul class="nav navbar-nav">
                <li><a href="/myeweek/information">My Account</a></li>
                <li><a href="/myeweek/subscriptions">My Subscriptions</a></li>
                <li><a href="#" onclick="EweekLogout();return false;">Log out</a></li>
            </ul>
        </div>
    </div>
    <div class="collapse navbar-collapse main-menu-collapse">
        <button type="button" class="topics-toggle hidden-lg" data-toggle="collapse" data-target=".topics-collapse">
            Topics <i class="glyphicon glyphicon-chevron-down"></i>
        </button>

                
<!-- Main Menu -->
<ul class="nav navbar-nav topics-collapse collapse hidden-lg">
                                        <li
            id="menu_82"
             data-related-id="51109"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/big-data-and-analytics"
                            >
                Big Data and Analytics
            </a>
                    </li>
                                        <li
            id="menu_95"
             data-related-id="47113"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/cloud"
                            >
                Cloud
            </a>
                    </li>
                                        <li
            id="menu_96"
             data-related-id="47091"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/mobile"
                            >
                Mobile
            </a>
                            
<div class="dropdown-menu">
    <div class="container">
        <div class="row subtopics">
            <div class="col-sm-3">
                                    <ul class="categories">
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/apple">
                                    Apple
                                </a>
                            </li>
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/blogs/upfront">
                                    Upfront Blog
                                </a>
                            </li>
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/android">
                                    Android
                                </a>
                            </li>
                                            </ul>
                            </div>
                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_97"
             data-related-id="47087"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/networking"
                            >
                Networking
            </a>
                    </li>
                                        <li
            id="menu_98"
             data-related-id="47101"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/security"
                            >
                Security
            </a>
                            
<div class="dropdown-menu">
    <div class="container">
        <div class="row subtopics">
            <div class="col-sm-3">
                                    <ul class="categories">
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/blogs/security-watch">
                                    Security Watch Blog
                                </a>
                            </li>
                                            </ul>
                            </div>
                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_99"
             data-related-id="47121"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/servers"
                            >
                Servers
            </a>
                    </li>
                                        <li
            id="menu_100"
             data-related-id="47117"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/storage"
                            >
                Storage
            </a>
                            
<div class="dropdown-menu">
    <div class="container">
        <div class="row subtopics">
            <div class="col-sm-3">
                                    <ul class="categories">
                                                                                                                                            <li>
                                <a href="http://www.eweek.com/blogs/storage-station">
                                    Storage Station Blog
                                </a>
                            </li>
                                            </ul>
                            </div>
                    </div>
    </div>
</div>
                    </li>
                                        <li
            id="menu_101"
             data-related-id="47115"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/virtualization"
                            >
                Virtualization
            </a>
                    </li>
                                        <li
            id="menu_102"
             data-related-id="47105"            class="dropdown"
        >
            <a
                href="http://www.eweek.com/innovation"
                            >
                Innovation
            </a>
                    </li>
                                        <li
            id="menu_103"
                        class="dropdown no-link"
        >
            <a
                href="#"
                 class="dropdown-arrow"            >
                More
            </a>
                            <div class="dropdown-menu">
    <ul>
                                                            <li
                id="menu_104"
                 data-related-id="47103"            >
                <a href="http://www.eweek.com/enterprise-apps">
                    Enterprise Apps                </a>
            </li>
                                                            <li
                id="menu_105"
                 data-related-id="47089"            >
                <a href="http://www.eweek.com/android">
                    Android                </a>
            </li>
                                                            <li
                id="menu_106"
                 data-related-id="47099"            >
                <a href="http://www.eweek.com/apple">
                    Apple                </a>
            </li>
                                                            <li
                id="menu_107"
                 data-related-id="47119"            >
                <a href="http://www.eweek.com/it-management">
                    IT Management                </a>
            </li>
                                                            <li
                id="menu_108"
                 data-related-id="47125"            >
                <a href="http://www.eweek.com/small-business">
                    Small Business                </a>
            </li>
                                                            <li
                id="menu_109"
                 data-related-id="47107"            >
                <a href="http://www.eweek.com/development">
                    Development                </a>
            </li>
                                                            <li
                id="menu_110"
                 data-related-id="47111"            >
                <a href="http://www.eweek.com/pc-hardware">
                    PC Hardware                </a>
            </li>
                                                            <li
                id="menu_112"
                 data-related-id="47129"            >
                <a href="http://www.eweek.com/database">
                    Database                </a>
            </li>
                                                            <li
                id="menu_47043"
                 data-related-id="47127"            >
                <a href="http://www.eweek.com/search-engines">
                    Search Engines                </a>
            </li>
            </ul>
</div>
                    </li>
    </ul>
<!-- /Main Menu -->

        
        <ul class="nav navbar-nav  resources-menu">
                                                                                <li
                    id="menu_83"
                     data-related-id="47095"                    
                                    >
                    <a
                        href="http://www.eweek.com/news"
                                                                    >
                        News &amp; Analysis
                    </a>
                                                        </li>
                                                                                <li
                    id="menu_84"
                     data-related-id="47139"                    
                                    >
                    <a
                        href="http://www.eweek.com/video"
                                                                    >
                        Videos
                    </a>
                                                        </li>
                                                                                <li
                    id="menu_113"
                     data-related-id="47199"                    
                                    >
                    <a
                        href="http://www.eweek.com/slideshows"
                                                                    >
                        Slideshows
                    </a>
                                                        </li>
                                                                                <li
                    id="menu_114"
                     data-related-id="47133"                    
                                    >
                    <a
                        href="http://www.eweek.com/blogs"
                                                                    >
                        Blogs
                    </a>
                                                        </li>
                                                                                <li
                    id="menu_115"
                     data-related-id="47387"                    
                     class="hidden-sm hidden-xs hidden-md"                >
                    <a
                        href="http://www.eweek.com/research"
                                                                    >
                        White Papers &amp; Webcasts
                    </a>
                                                        </li>
                                                                                <li
                    id="menu_116"
                                        
                                    >
                    <a
                        href="/SponsoredHub.php?prx_adpz=1141"
                                                                            rel="nofollow"
                                            >
                        Sponsored Content
                    </a>
                                                        </li>
                                                                                <li
                    id="menu_117"
                                        
                                    >
                    <a
                        href="/myeweek"
                                                                    >
                        My eWEEK
                    </a>
                                                        </li>
                    </ul>
    </div><!-- /.navbar-collapse -->
</nav><!-- END Navbar -->
<!-- /Main Menu -->

                    </div>
    </div>

        <div>
                            <script>
            if (myQSPfm == "des" || myQSPfm == "mob") {
                document.write("<div class=\"dfp_lb visible-lg-block visible-xs-block\" >");
                document.write("<!-- QS-AD: p1-lb start -->");
                var t = displayDFPTag("p1-lb");
                document.write(t);
                document.write("<!-- QS-AD: p1-lb end -->");
                document.write("</div>");
            }
        
</script>
        </div>

    <div class="container">
        <!-- dialogue boxes for login registration -->
        <div class="modal fade" id="eweek_login_frame" tabindex="-1" role="dialog" aria-labelledby="myModalLabel">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-body">
                        		<div id="loginDialog" class="contentLogin">
			<div id="container">
				<div class="dialogClose" onclick="closeDialog('#loginDialog','formLogin','#loginMessage', true)" ></div>
				<div class="formContentLogin">
					<div class="row">
						<div id="loginTitle" class="formHeader col-lg-5 col-sm-5 col-xs-5">Log in</div>
						<div id="loginlinkback_full" class="linkback formHeader col-lg-7 col-sm-7 col-xs-7 text-right">Don't have an Account? <a href="/myeweek/register">Sign up now</a></div>
						<div id="loginlinkback_fullmodal" class="linkback formHeader col-lg-7 col-sm-7 col-xs-7 text-right">Don't have an Account? <a href=# onclick="closeDialog('#loginDialog','formLogin','#loginMessage'); showDialog('#registerDialog');return false;">Sign up now</a></div>
						<div id="loginlinkback_light" class="linkback formHeader col-lg-7 col-sm-7 col-xs-7 text-right">Don't have an Account? <a href=# onclick="closeDialog('#loginDialog','formLogin','#loginMessage'); showDialog('#registerLightDialog');return false;">Sign up now</a></div>
					</div>
					<div class="hline"></div>

					<form class="formContainer form-horizontal" id="formLogin" name="formLogin" method="post" data-disable="false">
						<input id="ACL_Form_submit" name="submit" type="hidden" value="submit">
<input id="ACL_Form_loginForm" name="loginForm" type="hidden" value="">
<div id="p_loginEmail" class="form-group "><label id="l_loginEmail" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">E-mail Address:</label>
<div id="f_loginEmail" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_loginEmail"  name="loginEmail" type="email" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<div id="p_loginPassword" class="form-group"><label id="l_loginPassword" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Password:</label>
<div id="f_loginPassword" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input type="password"  name="loginPassword" id="ACL_Form_loginPassword" class="form-control" required value=""/><div class="help-block with-errors"></div></div></div>

                       <div class="row">
                           <div class="col-lg-6 col-md-6 col-sm-6 col-xs-6">
                               <button type="submit" id="login" name="login" class="btn btn-primary has-spinner" data-spinner="right">Log In ></button>
                           </div>
                            <div class="col-lg-6 col-md-6 col-sm-6 col-xs-6 text-right">
                                <a href="/myeweek/forgotpassword">Forgot Your Password?</a>
                            </div>
                       </div>
						<span class="error_sp">&nbsp; &nbsp; &nbsp; </span><div id="loginMessage" class="error"></div>
					</form>
				</div>
			</div>
		</div>

                                <div id="registerLightDialog" class="contentRegister">
            <div id="container">
                <div class="dialogClose" onclick="closeDialog('#registerLightDialog','formRegisterLight','#registrationLightMessage', true)" ></div>
                <div class="formContent">
                    <div class="row">
                        <div id="lightLoginTitle" class="formHeader no-qs-cookie col-lg-5 col-sm-5 col-xs-5">Create a new Account</div>
                        <div id="lightLoginTitle2" class="formHeader loginTitle col-lg-12 col-sm-12 col-xs-12 email-only-cookie biz-card-cookie social-user-cookie light-user-cookie hidden"><strong>Complete your registration.</strong></div>

                        <div class="col-lg-7 col-sm-7 col-xs-7 text-right no-qs-cookie">Already have an Account? <a href=# onclick="closeDialog('#registerLightDialog','formRegisterLight','#registrationLightMessage');showDialog('#loginDialog');return false;">Click here</a></div>
                    </div>
                    <div class="hline"></div>

                    <div class="myeweek_bold email-only-cookie biz-card-cookie social-user-cookie light-user-cookie hidden">
                        You're currently subscribed to some eWEEK features and just need to create a username and password.
                    </div>

                    <!-- BEGIN Form -->
                    <form class="formContainer form-horizontal" id="formRegisterLight" name="formRegisterLight" method="post" data-disable="false">
                        <input id="ACL_Form_submit" name="submit" type="hidden" value="submit">
<input id="ACL_Form_shownform" name="shownform" type="hidden" value="reglight">
<div id="p_light_EM" class="form-group "><label id="l_light_EM" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">E-mail Address:</label>
<div id="f_light_EM" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_light_EM"  name="light_EM" type="email" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<div id="p_light_Password" class="form-group"><label id="l_light_Password" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Password:</label>
<div id="f_light_Password" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input type="password"  name="light_Password" id="ACL_Form_light_Password" class="form-control" required value=""/><div class="help-block with-errors"></div></div></div>
<div id="p_light_ConfirmPassword" class="form-group"><label id="l_light_ConfirmPassword" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Re-Type Password:</label>
<div id="f_light_ConfirmPassword" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input type="password"  name="light_ConfirmPassword" id="ACL_Form_light_ConfirmPassword" class="form-control" required value=""/><div class="help-block with-errors"></div></div></div>
<div id="p_light_UserDisplayName" class="form-group "><label id="l_light_UserDisplayName" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Username:</label>
<div id="f_light_UserDisplayName" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_light_UserDisplayName"  name="light_UserDisplayName" type="text" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<input id="ACL_Form_light_UserAvatar" name="light_UserAvatar" type="hidden" value="/bundles/qsgigya/images/avatar_48x48.gif">
<p id="p_light_NewsletterKeys" class="Form_radiolabel"><label id="l_light_NewsletterKeys">Your registration with Eweek will include the following free email newsletter(s):</label>
<label class="Form_radiolabel radio-inline"><input id="ACL_Form_light_NewsletterKeys" name="light_NewsletterKeys" type="checkbox" value="10110" >News & Views</label>

</p>
                        <div class="form-group col-lg-12 col-md-12 col-sm-12 col-xs-12">
                            <button type="submit" id="registerlight" name="registerlight" class="btn btn-primary has-spinner" data-spinner="right">Register</button>
                        </div>
                        <span class="error_sp">&nbsp; &nbsp; &nbsp; </span><div id="registrationLightMessage" class="error">&nbsp;</div>
                    </form>
                    <!-- END Form -->
                    <!-- Form Temp  -->
                    <div class="p_temp"></div>
                    <!-- END Form Temp  -->
                </div>
            </div>
        </div>                        		<div id="linkAccountDialog" class="contentLogin">
			<div id="container">
				<div class="dialogClose" onclick="closeDialog('#linkAccountDialog','linkForm','#linkAccountMessage', true);"></div>
				<div class="formContent">
					<div>
						<div class="userImage" >
							<img id="linkUserImage" src="/bundles/qsgigya/images/user_dialogs/avatar_100px.jpg" style="width:40px;" />
						</div>
						<span id="userMainDetails" class="formHeader loginTitle">
							Would you like to link your Social account to eWEEK?
						</span>
					</div>
					<div class="hline"></div>
					
					<div class="eweek_logo_div">
						<img class="eweek_logo" src="/bundles/eweekbase/images/logo_eweek.jpg" alt="eWeek - Enterprise IT Technology News, Opinion and Reviews"/>
					</div>

					<div id="inheaderlinkAccount">				
						<div class="linkNewText">You already have <span class="normalaccntlink">an account</span><span class="socialaccntlink">a social account</span> with us.<br>Link your accounts to manage all your info in one place.</div>
					</div>

					<form id="linkForm" name="linkForm" class="formContainer form-horizontal" data-toggle="validator" method="post">
                        <div id="p_linkEmail" class="form-group ">
                            <label id="l_linkEmail" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">E-mail Address:</label>
                            <div id="text_linkEmail" class="col-lg-9 col-md-9 col-sm-9 col-xs-8 myeweek_hidden"></div>
                            <div id="d_linkEmail" class="col-lg-9 col-md-9 col-sm-9 col-xs-8 myeweek_hidden">
                                <input id="linkEmail" class="form-control" type="email" name="linkEmail">
	                            <div class="help-block with-errors"></div>
    	                    </div>
                        </div>

                        <div class="form-group col-lg-12 col-md-12 col-sm-12 col-xs-12 myeweek_center">
                            <button type="submit" id="linkAccount" name="linkAccount" class="btn btn-primary">Yes, Link My Accounts</button>
                            <div class="myeweek_vspace"></div>
							<a href="#" class="" onclick="closeDialog('#linkAccountDialog','linkForm','#linkAccountMessage');showDialog('#loginDialog','formLogin','#loginMessage');return false;">No Thanks, I will login with my current <span class="socialaccntlink">social </span>account</a>
                        </div>

						<span class="error_sp">&nbsp; &nbsp; &nbsp;</span><div id="linkAccountMessage" class="error">&nbsp;</div>
					</form>
				</div>
			</div>
		</div> 
                        		<div id="linkSocialAccountDialog" class="contentRegister">	
			<div id="container">
				<div class="dialogClose" onclick="closeDialog('#linkSocialAccountDialog','linkSocialForm','#linkSocialAccountMessage', true)" ></div>
				<div class="formContent">
					<div>
						<div class="userImage" >
							<img id="linkSocialUserImage" src="/bundles/qsgigya/images/user_dialogs/avatar_100px.jpg" style="width:40px;" />
						</div>
						<span id="userMainDetails" class="formHeader loginTitle">
							Would you like to link your Social account to eWEEK?
						</span>
					</div>
					<div class="hline"></div>

 					<div class="eweek_logo_div">
						<img class="eweek_logo" src="/bundles/eweekbase/images/logo_eweek.jpg" alt="eWeek - Enterprise IT Technology News, Opinion and Reviews"/>
					</div>

					<div id="inheaderlinkSocialAccount">				
						<div class="linkNewText">Linking your Social and eWEEK accounts makes it easier to manage your profile and subscriptions, all in one place.</div>
					</div>

					<form id="linkSocialForm" name="linkSocialForm" class="formContainer form-horizontal" data-toggle="validator" method="post">
                        <div id="p_linkSocialEmail" class="form-group ">
                            <label id="l_linkSocialEmail" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">E-mail Address:</label>
                                <div class="col-lg-9 col-md-9 col-sm-9 col-xs-8">
                                     <input id="linkSocialEmail" class="form-control" type="email" required="" name="linkSocialEmail">
                                <div class="help-block with-errors"></div>
                            </div>
                        </div>

                        <div id="p_linkSocialPassword" class="form-group ">
                            <label id="l_linkSocialPassword" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Password:</label>
                                <div class="col-lg-9 col-md-9 col-sm-9 col-xs-8">
                                     <input id="linkSocialPassword" class="form-control" type="email" required="" name="linkSocialPassword">
                                <div class="help-block with-errors"></div>
                            </div>
                        </div>


                        <div class="form-group col-lg-12 col-md-12 col-sm-12 col-xs-12">
                            <button type="submit" id="linkSocialAccount" name="linkSocialAccount" class="btn btn-primary">Link Account</button>
							<a href="#" class="btn btn-primary" onclick="closeDialog('#linkSocialAccountDialog','linkForm','#linkSocialAccountMessage', true);return false;">No Thanks</a>
                        </div>

						<span class="error_sp">&nbsp; &nbsp; &nbsp;</span><div id="linkSocialAccountMessage" class="error">&nbsp;</div>
					</form>
				</div>
			</div>	
		</div> 
	
                        		<div id="provideEmailDialog" class="contentLogin">
			<div id="container">
				<div class="dialogClose" onclick="closeDialog('#provideEmailDialog','emailForm','#provideEmailMessage', true)" ></div>
				<div class="formContent">
					<div class="row">
						<span id="ProvideEmailTitle" class="formHeader myeweek_header col-lg-12 col-sm-12 col-xs-12">We need just a little more information ...</span>
					</div>
					<div class="hline"></div>

 					<div class="eweek_logo_div">
						<img class="eweek_logo" src="/bundles/eweekbase/images/logo_eweek.jpg" alt="eWeek - Enterprise IT Technology News, Opinion and Reviews"/>
					</div>

					<div id="inheaderprovideEmail">				
						<div class="linkNewText">Please provide the following information to complete your registration.</div>
					</div>

					<form id="emailForm" name="emailForm" class="formContainer form-horizontal" data-toggle="validator" method="post">
						<input id="ACL_Form_missingsubmit" name="missingsubmit" type="hidden" value="submit">
<div id="p_missingEM" class="form-group "><label id="l_missingEM" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">E-mail Address:</label>
<div id="f_missingEM" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_missingEM"  name="missingEM" type="email" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<input id="ACL_Form_missingUserDisplayName" name="missingUserDisplayName" type="hidden" value="">
<input id="ACL_Form_missingUserAvatar" name="missingUserAvatar" type="hidden" value="">

                        <div class="form-group col-lg-12 col-md-12 col-sm-12 col-xs-12">
                            <button type="submit" id="provideEmail" name="provideEmail" class="btn btn-primary">Register</button>
                        </div>
						<span class="error_sp">&nbsp; &nbsp; &nbsp; </span><div id="provideEmailMessage" class="error">&nbsp;</div>
					</form>
				</div>	
			</div>
		</div> 
            			                <!-- Full Registration content -->
            <div id="registerDialog" class="contentRegister">
                <div id="container" class="row">
                    <!-- Form  -->
                    <div id="formRegisterDiv" class="formContent">
                        <div class="dialogClose" onclick="closeDialog('#registerDialog','formRegister','#registrationMessage', true)" ></div>
                        <div class="row register-header">
                            <div id="RegistrationTitle1" class="col-lg-6 col-sm-6 col-xs-6 myeweek_header no-qs-cookie">Sign Me Up</div>
                            <div id="RegistrationTitle2" class="col-lg-12 col-sm-12 col-xs-12 email-only-cookie biz-card-cookie social-user-cookie light-user-cookie hidden"><strong>Complete your registration to get access to all of eWEEK's great content and community features.</strong></div>

                            <div class="col-lg-6 col-sm-6 col-xs-6 linkback text-right no-qs-cookie">Already Registered? <a href=# onclick="showGFrame('login', 'fullmodal');return false;">Click here</a></div>
                        </div>
                        <div>
                            <form class="formContainer form-horizontal" id="formRegister" name="formRegister" method="post" data-disable="false">
                                <div id="p_FN" class="form-group "><label id="l_FN" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">First Name:</label>
<div id="f_FN" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_FN"  name="FN" type="text" class="form-control" pattern="^.{2,30}$" data-pattern-error="Entry must have 2-30 characters"   required/><div class="help-block with-errors"></div></div></div>
<div id="p_LN" class="form-group "><label id="l_LN" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Last Name:</label>
<div id="f_LN" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_LN"  name="LN" type="text" class="form-control" pattern="^.{2,30}$" data-pattern-error="Entry must have 2-30 characters"   required/><div class="help-block with-errors"></div></div></div>
<div id="p_EM" class="form-group "><label id="l_EM" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">E-mail Address:</label>
<div id="f_EM" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_EM"  name="EM" type="email" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<div id="p_Password" class="form-group"><label id="l_Password" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Password:</label>
<div id="f_Password" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input type="password" pattern="^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d$@$!%*#?&]{6,}$" data-pattern-error="Password must be at least 6 characters and must include a letter and a digit" data-toggle="validator" name="Password" id="ACL_Form_Password" class="form-control" required value=""/><div class="help-block with-errors"></div></div></div>
<div id="p_ConfirmPassword" class="form-group"><label id="l_ConfirmPassword" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Confirm Password:</label>
<div id="f_ConfirmPassword" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input type="password" data-match="#ACL_Form_Password" data-match-error="Confirm password is not matching" name="ConfirmPassword" id="ACL_Form_ConfirmPassword" class="form-control" required value=""/><div class="help-block with-errors"></div></div></div>
<div id="p_UserDisplayName" class="form-group "><label id="l_UserDisplayName" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Username:</label>
<div id="f_UserDisplayName" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_UserDisplayName"  name="UserDisplayName" type="text" class="form-control" pattern="^.{2,30}$" data-pattern-error="Entry must have 2-30 characters"   required/><div class="help-block with-errors"></div></div></div>
<div id="p_Designation" class="form-group radio-form-group custom-radio-form-group "><label id="l_Designation" class="control-label" required>Title:</label>
<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_Designation" name="Designation" type="radio" required value="C-Level/President" >C-Level/President</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_Designation" name="Designation" type="radio" required value="Manager" >Manager</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_Designation" name="Designation" type="radio" required value="VP" >VP</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_Designation" name="Designation" type="radio" required value="Staff (Associate/Analyst/etc.)" >Staff (Associate/Analyst/etc.)</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_Designation" name="Designation" type="radio" required value="Director" >Director</label>

</div><div id="p_JobFunction" class="form-group "><label id="l_JobFunction" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label" required>Function:</label><div id="f_JobFunction" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><select class="form-control" name="JobFunction" id="ACL_Form_JobFunction" data-error="Please select Function."  required>
<option selected="True" value="">--- Select One ---</option>
<option value="IT - General" order="0">IT - General</option>
<option value="IT - Project Management" order="1">IT - Project Management</option>
<option value="IT - Systems/Network Administration" order="2">IT - Systems/Network Administration</option>
<option value="IT - Developer" order="3">IT - Developer</option>
<option value="IT - Tester/QA" order="4">IT - Tester/QA</option>
<option value="Accounting/Finance/Legal" order="5">Accounting/Finance/Legal</option>
<option value="Academic/Research" order="6">Academic/Research</option>
<option value="Administrative" order="7">Administrative</option>
<option value="General Management" order="8">General Management</option>
<option value="Human Resources" order="9">Human Resources</option>
<option value="Marketing" order="10">Marketing</option>
<option value="Operations" order="11">Operations</option>
<option value="Sales" order="12">Sales</option>
<option value="Consultant" order="13">Consultant</option>
<option value="Other" order="14">Other</option>
</select><div class="help-block with-errors"></div></div></div><div id="p_DecisionRole" class="form-group radio-form-group custom-radio-form-group "><label id="l_DecisionRole" class="control-label" required>Role in IT decision-making process:</label>
<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Align Business & IT Goals" >Align Business & IT Goals</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Create IT Strategy" >Create IT Strategy</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Determine IT Needs" >Determine IT Needs</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Manage Vendor Relationships" >Manage Vendor Relationships</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Evaluate/Specify Brands or Vendors" >Evaluate/Specify Brands or Vendors</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Other Role in IT Decision Making Process" >Other Role</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Authorize Purchases" >Authorize Purchases</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_DecisionRole" name="DecisionRole" type="radio" required value="Not Involved in IT Decision Making Process" >Not Involved</label>

</div><div id="p_WP" class="form-group "><label id="l_WP" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Work Phone:</label>
<div id="f_WP" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_WP"  name="WP" type="text" class="form-control"  autocomplete="off" pattern="^[\d]{8,30}$" data-pattern-error="Invalid Work Phone. Must be 8 numbers or longer" required/><div class="help-block with-errors"></div></div></div>
<div id="p_CompanyName" class="form-group "><label id="l_CompanyName" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Company:</label>
<div id="f_CompanyName" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_CompanyName"  name="CompanyName" type="text" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<div id="p_NumberofEmployeesRange" class="form-group hidden"><label id="l_NumberofEmployeesRange" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label" required>Company Size:</label><div id="f_NumberofEmployeesRange" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><select class="form-control" name="NumberofEmployeesRange" id="ACL_Form_NumberofEmployeesRange" data-error="Please select Company Size."  required>
<option selected="True" value="">--- Select One ---</option>
<option value="9" order="0">1-9</option>
<option value="24" order="1">10-24</option>
<option value="49" order="2">25-49</option>
<option value="99" order="3">50-99</option>
<option value="249" order="4">100-249</option>
<option value="499" order="5">250-499</option>
<option value="999" order="6">500-999</option>
<option value="1999" order="7">1000-1999</option>
<option value="4999" order="8">2000-4999</option>
<option value="9999" order="9">5000-9999</option>
<option value="10000" order="10">10,000 or More</option>
</select><div class="help-block with-errors"></div></div></div><div id="p_Industry" class="form-group hidden"><label id="l_Industry" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label" required>Industry:</label><div id="f_Industry" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><select class="form-control" name="Industry" id="ACL_Form_Industry" data-error="Please select Industry."  required>
<option selected="True" value="">--- Select One ---</option>
<option value="Aerospace & Defense" order="0">Aerospace & Defense</option>
<option value="Agriculture" order="1">Agriculture</option>
<option value="Apparel & Textiles" order="2">Apparel & Textiles</option>
<option value="Associations" order="3">Associations</option>
<option value="Automotive" order="4">Automotive</option>
<option value="Biotech" order="5">Biotech</option>
<option value="Business Services" order="6">Business Services</option>
<option value="Computer Hardware/Software/Technology Manufacturer" order="7">Computer Hardware/Software/Technology Manufacturer</option>
<option value="Computer Services/Consulting" order="8">Computer Services/Consulting</option>
<option value="Computer/Technology Reseller" order="9">Computer/Technology Reseller</option>
<option value="Construction/Architecture/Engineering" order="10">Construction/Architecture/Engineering</option>
<option value="Consumer Goods & Services" order="11">Consumer Goods & Services</option>
<option value="Education" order="12">Education</option>
<option value="Electronics" order="13">Electronics</option>
<option value="Energy & Utilities" order="14">Energy & Utilities</option>
<option value="Financial Services" order="15">Financial Services</option>
<option value="Food & Beverage" order="16">Food & Beverage</option>
<option value="Furniture" order="17">Furniture</option>
<option value="Government - Federal" order="18">Government - Federal</option>
<option value="Government - State & Local" order="19">Government - State & Local</option>
<option value="Hardware" order="20">Hardware</option>
<option value="Healthcare & Medical" order="21">Healthcare & Medical</option>
<option value="Home & Garden" order="22">Home & Garden</option>
<option value="Hospitality & Travel" order="23">Hospitality & Travel</option>
<option value="Legal" order="24">Legal</option>
<option value="Manufacturing" order="25">Manufacturing</option>
<option value="Media & Entertainment" order="26">Media & Entertainment</option>
<option value="Mining" order="27">Mining</option>
<option value="Non-Profit" order="28">Non-Profit</option>
<option value="Other" order="29">Other</option>
<option value="Pharmaceutical" order="30">Pharmaceuticals</option>
<option value="Printing & Publishing" order="31">Printing & Publishing</option>
<option value="Real Estate" order="32">Real Estate</option>
<option value="Recreation" order="33">Recreation</option>
<option value="Retail & Distribution" order="34">Retail & Distribution</option>
<option value="Telecommunications" order="35">Telecommunications</option>
<option value="Transportation & Logistics" order="36">Transportation & Logistics</option>
</select><div class="help-block with-errors"></div></div></div><div id="p_S1" class="form-group hidden"><label id="l_S1" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Street Address</label>
<div id="f_S1" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_S1"  name="S1" type="text" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<div id="p_CT" class="form-group hidden"><label id="l_CT" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">City:</label>
<div id="f_CT" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_CT"  name="CT" type="text" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<div id="p_PC" class="form-group hidden"><label id="l_PC" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label text-left">Zip/postal code</label>
<div id="f_PC" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><input id="ACL_Form_PC"  name="PC" type="text" class="form-control"    required/><div class="help-block with-errors"></div></div></div>
<div id="p_SP" class="form-group hidden"><label id="l_SP" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label" required>State/Province:</label><div id="f_SP" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><select class="form-control" name="SP" id="ACL_Form_SP" data-error="Please select State."  required>
<option selected="True" value="">--- Select One ---</option>
<option value="AL" order="0">Alabama</option>
<option value="AK" order="1">Alaska</option>
<option value="AZ" order="2">Arizona</option>
<option value="AR" order="3">Arkansas</option>
<option value="AA" order="4">Armed Forces Americas</option>
<option value="AE" order="5">Armed Forces Europe</option>
<option value="AP" order="6">Armed Forces Pacific</option>
<option value="CA" order="7">California</option>
<option value="CO" order="8">Colorado</option>
<option value="CT" order="9">Connecticut</option>
<option value="DE" order="10">Delaware</option>
<option value="DC" order="11">District of Columbia</option>
<option value="FL" order="12">Florida</option>
<option value="GA" order="13">Georgia</option>
<option value="HI" order="14">Hawaii</option>
<option value="ID" order="15">Idaho</option>
<option value="IL" order="16">Illinois</option>
<option value="IN" order="17">Indiana</option>
<option value="IA" order="18">Iowa</option>
<option value="KS" order="19">Kansas</option>
<option value="KY" order="20">Kentucky</option>
<option value="LA" order="21">Louisiana</option>
<option value="ME" order="22">Maine</option>
<option value="MD" order="23">Maryland</option>
<option value="MA" order="24">Massachusetts</option>
<option value="MI" order="25">Michigan</option>
<option value="MN" order="26">Minnesota</option>
<option value="MS" order="27">Mississippi</option>
<option value="MO" order="28">Missouri</option>
<option value="MT" order="29">Montana</option>
<option value="NE" order="30">Nebraska</option>
<option value="NV" order="31">Nevada</option>
<option value="NH" order="32">New Hampshire</option>
<option value="NJ" order="33">New Jersey</option>
<option value="NM" order="34">New Mexico</option>
<option value="NY" order="35">New York</option>
<option value="NC" order="36">North Carolina</option>
<option value="ND" order="37">North Dakota</option>
<option value="OH" order="38">Ohio</option>
<option value="OK" order="39">Oklahoma</option>
<option value="OR" order="40">Oregon</option>
<option value="PA" order="41">Pennsylvania</option>
<option value="PR" order="42">Puerto Rico</option>
<option value="RI" order="43">Rhode Island</option>
<option value="SC" order="44">South Carolina</option>
<option value="SD" order="45">South Dakota</option>
<option value="TN" order="46">Tennessee</option>
<option value="TX" order="47">Texas</option>
<option value="UT" order="48">Utah</option>
<option value="VT" order="49">Vermont</option>
<option value="VA" order="50">Virginia</option>
<option value="WA" order="51">Washington</option>
<option value="WV" order="52">West Virginia</option>
<option value="WI" order="53">Wisconsin</option>
<option value="WY" order="54">Wyoming</option>
</select><div class="help-block with-errors"></div></div></div><div id="p_CN" class="form-group hidden"><label id="l_CN" class="col-lg-3 col-md-3 col-sm-3 col-xs-4 control-label" required>Country:</label><div id="f_CN" class="col-lg-9 col-md-9 col-sm-9 col-xs-8"><select class="form-control" name="CN" id="ACL_Form_CN" data-error="Please select Country."  required>
<option selected="True" value="">--- Select One ---</option>
<option value="ZZ" order="0">(Unspecified)</option>
<option value="AF" order="1">Afghanistan</option>
<option value="AL" order="2">Albania</option>
<option value="DZ" order="3">Algeria</option>
<option value="AD" order="4">Andorra</option>
<option value="AO" order="5">Angola</option>
<option value="AI" order="6">Anguilla</option>
<option value="AQ" order="7">Antarctica</option>
<option value="AG" order="8">Antigua & Barbuda</option>
<option value="AR" order="9">Argentina</option>
<option value="AM" order="10">Armenia</option>
<option value="AW" order="11">Aruba</option>
<option value="AU" order="12">Australia</option>
<option value="AT" order="13">Austria</option>
<option value="AZ" order="14">Azerbaijan</option>
<option value="BS" order="15">Bahamas</option>
<option value="BH" order="16">Bahrain</option>
<option value="BD" order="17">Bangladesh</option>
<option value="BB" order="18">Barbados</option>
<option value="BY" order="19">Belarus</option>
<option value="BE" order="20">Belgium</option>
<option value="BZ" order="21">Belize</option>
<option value="BJ" order="22">Benin</option>
<option value="BM" order="23">Bermuda</option>
<option value="BT" order="24">Bhutan</option>
<option value="BO" order="25">Bolivia</option>
<option value="BA" order="26">Bosnia-Herzegovina</option>
<option value="BW" order="27">Botswana</option>
<option value="BV" order="28">Bouvet Island</option>
<option value="BR" order="29">Brazil</option>
<option value="VG" order="30">British Virgin Islands</option>
<option value="BN" order="31">Brunei</option>
<option value="BG" order="32">Bulgaria</option>
<option value="BF" order="33">Burkina Faso</option>
<option value="BI" order="34">Burundi</option>
<option value="KH" order="35">Cambodia</option>
<option value="CM" order="36">Cameroon</option>
<option value="CA" order="37">Canada</option>
<option value="CV" order="38">Cape Verde</option>
<option value="KY" order="39">Cayman Islands</option>
<option value="CF" order="40">Central African Republic</option>
<option value="TD" order="41">Chad</option>
<option value="CL" order="42">Chile</option>
<option value="CN" order="43">China</option>
<option value="CO" order="44">Colombia</option>
<option value="KM" order="45">Comoros</option>
<option value="CG" order="46">Congo</option>
<option value="CK" order="47">Cook Islands</option>
<option value="CR" order="48">Costa Rica</option>
<option value="CI" order="49">Cote D'ivoire</option>
<option value="HR" order="50">Croatia</option>
<option value="CU" order="51">Cuba</option>
<option value="CY" order="52">Cyprus</option>
<option value="CZ" order="53">Czech Republic</option>
<option value="DK" order="54">Denmark</option>
<option value="DJ" order="55">Djibouti</option>
<option value="DM" order="56">Dominica</option>
<option value="DO" order="57">Dominican Republic</option>
<option value="TP" order="58">East Timor</option>
<option value="EC" order="59">Ecuador</option>
<option value="EG" order="60">Egypt</option>
<option value="SV" order="61">El Salvador</option>
<option value="GQ" order="62">Equatorial Guinea</option>
<option value="ER" order="63">Eritrea</option>
<option value="EE" order="64">Estonia</option>
<option value="ET" order="65">Ethiopia</option>
<option value="FK" order="66">Falkland Islands</option>
<option value="FO" order="67">Faroe Islands</option>
<option value="FJ" order="68">Fiji</option>
<option value="FI" order="69">Finland</option>
<option value="FR" order="70">France</option>
<option value="GF" order="71">French Guiana</option>
<option value="PF" order="72">French Polynesia</option>
<option value="GA" order="73">Gabon</option>
<option value="GM" order="74">Gambia</option>
<option value="GE" order="75">Georgia</option>
<option value="DE" order="76">Germany</option>
<option value="GH" order="77">Ghana</option>
<option value="GI" order="78">Gibraltar</option>
<option value="GR" order="79">Greece</option>
<option value="GL" order="80">Greenland</option>
<option value="GD" order="81">Grenada</option>
<option value="GP" order="82">Guadeloupe</option>
<option value="GT" order="83">Guatemala</option>
<option value="GN" order="84">Guinea</option>
<option value="GW" order="85">Guinea-Bissau</option>
<option value="GY" order="86">Guyana</option>
<option value="HT" order="87">Haiti</option>
<option value="HN" order="88">Honduras</option>
<option value="HK" order="89">Hong Kong</option>
<option value="HU" order="90">Hungary</option>
<option value="IS" order="91">Iceland</option>
<option value="IN" order="92">India</option>
<option value="ID" order="93">Indonesia</option>
<option value="IQ" order="94">Iraq</option>
<option value="IE" order="95">Ireland</option>
<option value="IR" order="96">Islamic Republic of Iran</option>
<option value="IL" order="97">Israel</option>
<option value="IT" order="98">Italy</option>
<option value="JM" order="99">Jamaica</option>
<option value="JP" order="100">Japan</option>
<option value="JO" order="101">Jordan</option>
<option value="KZ" order="102">Kazakhstan</option>
<option value="KE" order="103">Kenya</option>
<option value="KI" order="104">Kiribati</option>
<option value="KP" order="105">Korea, DPRK</option>
<option value="KR" order="106">Korea, ROK</option>
<option value="KW" order="107">Kuwait</option>
<option value="KG" order="108">Kyrgyzstan</option>
<option value="LA" order="109">Laos</option>
<option value="LV" order="110">Latvia</option>
<option value="LB" order="111">Lebanon</option>
<option value="LS" order="112">Lesotho</option>
<option value="LR" order="113">Liberia</option>
<option value="LY" order="114">Libya</option>
<option value="LI" order="115">Liechtenstein</option>
<option value="LT" order="116">Lithuania</option>
<option value="LU" order="117">Luxembourg</option>
<option value="MO" order="118">Macau</option>
<option value="MG" order="119">Madagascar</option>
<option value="MW" order="120">Malawi</option>
<option value="MY" order="121">Malaysia</option>
<option value="MV" order="122">Maldives</option>
<option value="ML" order="123">Mali</option>
<option value="MT" order="124">Malta</option>
<option value="MQ" order="125">Martinique</option>
<option value="MR" order="126">Mauritania</option>
<option value="MU" order="127">Mauritius</option>
<option value="YT" order="128">Mayotte</option>
<option value="MX" order="129">Mexico</option>
<option value="MD" order="130">Moldova</option>
<option value="MC" order="131">Monaco</option>
<option value="MN" order="132">Mongolia</option>
<option value="MS" order="133">Monserrat</option>
<option value="MA" order="134">Morocco</option>
<option value="MZ" order="135">Mozambique</option>
<option value="MM" order="136">Myanmar (Burma)</option>
<option value="NA" order="137">Nambia</option>
<option value="NR" order="138">Nauru</option>
<option value="NP" order="139">Nepal</option>
<option value="NL" order="140">Netherlands</option>
<option value="AN" order="141">Netherlands Antilles</option>
<option value="NC" order="142">New Caledonia</option>
<option value="NZ" order="143">New Zealand</option>
<option value="NI" order="144">Nicaragua</option>
<option value="NE" order="145">Niger</option>
<option value="NG" order="146">Nigeria</option>
<option value="NU" order="147">Niue</option>
<option value="NF" order="148">Norfolk Island</option>
<option value="NO" order="149">Norway</option>
<option value="OM" order="150">Oman</option>
<option value="PK" order="151">Pakistan</option>
<option value="PA" order="152">Panama</option>
<option value="PG" order="153">Papua New Guinea</option>
<option value="PY" order="154">Paraguay</option>
<option value="PE" order="155">Peru</option>
<option value="PH" order="156">Philippines</option>
<option value="PN" order="157">Pitcairn</option>
<option value="PL" order="158">Poland</option>
<option value="PT" order="159">Portugal</option>
<option value="QA" order="160">Qatar</option>
<option value="RE" order="161">Reunion</option>
<option value="RO" order="162">Romania</option>
<option value="RU" order="163">Russian Federation</option>
<option value="RW" order="164">Rwanda</option>
<option value="LC" order="165">Saint Lucia</option>
<option value="WS" order="166">Samoa</option>
<option value="SM" order="167">San Marino</option>
<option value="ST" order="168">Sao Tome & Principe</option>
<option value="SA" order="169">Saudi Arabia</option>
<option value="SN" order="170">Senegal</option>
<option value="SC" order="171">Seychelles</option>
<option value="SL" order="172">Sierra Leone</option>
<option value="SG" order="173">Singapore</option>
<option value="SK" order="174">Slovakia</option>
<option value="SI" order="175">Slovenia</option>
<option value="SB" order="176">Solomon Islands</option>
<option value="SO" order="177">Somalia</option>
<option value="ZA" order="178">South Africa</option>
<option value="ES" order="179">Spain</option>
<option value="LK" order="180">Sri Lanka</option>
<option value="SH" order="181">St. Helena</option>
<option value="PM" order="182">St. Pierre & Miquelon</option>
<option value="SD" order="183">Sudan</option>
<option value="SR" order="184">Suriname</option>
<option value="SZ" order="185">Swaziland</option>
<option value="SE" order="186">Sweden</option>
<option value="CH" order="187">Switzerland</option>
<option value="SY" order="188">Syria</option>
<option value="TW" order="189">Taiwan</option>
<option value="TJ" order="190">Tajikistan</option>
<option value="TZ" order="191">Tanzania</option>
<option value="TH" order="192">Thailand</option>
<option value="TG" order="193">Togo</option>
<option value="TK" order="194">Tokelau</option>
<option value="TO" order="195">Tonga</option>
<option value="TT" order="196">Trinidad & Tobago</option>
<option value="TN" order="197">Tunisia</option>
<option value="TR" order="198">Turkey</option>
<option value="TM" order="199">Turkmenistan</option>
<option value="TV" order="200">Tuvalu</option>
<option value="UM" order="201">U.S. Pacific Islands</option>
<option value="UG" order="202">Uganda</option>
<option value="UA" order="203">Ukraine</option>
<option value="AE" order="204">United Arab Emirates</option>
<option value="GB" order="205">United Kingdom</option>
<option value="US" order="206">United States</option>
<option value="UY" order="207">Uruguay</option>
<option value="UZ" order="208">Uzbekistan</option>
<option value="VU" order="209">Vanuatu</option>
<option value="VA" order="210">Vatican City (Holy See)</option>
<option value="VE" order="211">Venezuela</option>
<option value="VN" order="212">Vietnam</option>
<option value="EH" order="213">Western Sahara</option>
<option value="YE" order="214">Yemen</option>
<option value="YU" order="215">Yugoslavia</option>
<option value="ZR" order="216">Zaire</option>
<option value="ZM" order="217">Zambia</option>
<option value="ZW" order="218">Zimbabwe</option>
</select><div class="help-block with-errors"></div></div></div><div id="p_AnnouncementList" class="form-group radio-form-group custom-radio-form-group "><label id="l_AnnouncementList" class="control-label" required>Occasionally, we send subscribers special offers from select partners. Would you like to receive these special partner offers via e-mail?</label>
<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_AnnouncementList" name="AnnouncementList" type="radio" required value="Y" checked="checked">Yes</label>

<label class="Form_radiolabel col-lg-5 col-sm-5 col-xs-12 radio-inline"><input id="ACL_Form_AnnouncementList" name="AnnouncementList" type="radio" required value="N" >No</label>

</div><input id="ACL_Form_Primary_Sic" name="Primary_Sic" type="hidden" value="">
<input id="ACL_Form_Revenue_Range" name="Revenue_Range" type="hidden" value="">
<input id="ACL_Form_Sub_Industry" name="Sub_Industry" type="hidden" value="">
<input id="ACL_Form_CompanyWebSiteURL" name="CompanyWebSiteURL" type="hidden" value="">
<input id="ACL_Form_Marketing_Alias" name="Marketing_Alias" type="hidden" value="">
<input id="ACL_Form_JobTitle" name="JobTitle" type="hidden" value="">
<input id="ACL_Form_Employee_Range" name="Employee_Range" type="hidden" value="">
<input id="ACL_Form_SICDescription" name="SICDescription" type="hidden" value="">
<input id="ACL_Form_LinkedInProfile" name="LinkedInProfile" type="hidden" value="">
<input id="ACL_Form_EmailType" name="EmailType" type="hidden" value="">
<input id="ACL_Form_DUNS" name="DUNS" type="hidden" value="">
<input id="ACL_Form_EmailThreatRisk" name="EmailThreatRisk" type="hidden" value="">
<input id="ACL_Form_EmailDeliverabilityRating" name="EmailDeliverabilityRating" type="hidden" value="">
<input id="ACL_Form_EmailDisposition" name="EmailDisposition" type="hidden" value="">
<input id="ACL_Form_NetProspexContactID" name="NetProspexContactID" type="hidden" value="">
<p id="p_NewsletterKeys" class="Form_radiolabel"><label id="l_NewsletterKeys">Your registration with Eweek will include the following free email newsletter(s):</label>
<label class="Form_radiolabel radio-inline"><input id="ACL_Form_NewsletterKeys" name="NewsletterKeys" type="checkbox" value="10110" >News & Views</label>

</p><input id="ACL_Form_WorkPhoneConsent" name="WorkPhoneConsent" type="hidden" value="No">
<p id="prompt_WorkPhoneConsent" style="display:none" class="Form_FieldContainer">By submitting your wireless number, you agree that eWEEK, its related properties, and vendor partners providing content you view may contact you using contact center technology.  Your consent is not required to view content or use site features.</p>
<input id="ACL_Form_WorkPhoneConsentLanguage" name="WorkPhoneConsentLanguage" type="hidden" value="NA">
<input id="ACL_Form_WorkPhoneType" name="WorkPhoneType" type="hidden" value="NotWireless">
<input id="ACL_Form_WorkPhoneConsentDate" name="WorkPhoneConsentDate" type="hidden" value="NA">
<input id="ACL_Form_CBQ" name="CBQ" type="hidden" value="">

                                <div class="myeweek_vspace"></div>
                                <div class="form-group">
                                    <p class="text-muted"">By clicking on the "Register" button below, I agree that I have carefully read the <a target="_blank" href="http://www.eweek.com/terms">Terms of Service</a> and the <a target="_blank" href="http://www.eweek.com/privacy">Privacy Policy</a> and I agree to be legally bound by all such terms.</p>
                                </div>
                                <div class="form-group">
                                    <button type="submit" id="register" name="register" class="btn btn-primary has-spinner text-center col-lg-2 col-lg-offset-5 col-md-2 col-md-offset-5 col-sm-2 col-sm-offset-5 col-xs-3 col-xs-offset-5" data-spinner="right">Register</button>
                                </div>
                                <div id="submitLink" class="submitLinkPopup">
                                    <a id="consentSubmit" href="#"> Continue without consent </a>
                                </div>
                            <span class="error_sp">&nbsp; &nbsp; &nbsp; </span><div id="registrationMessage" class="error">&nbsp;</div>
                            </form>
                        </div>
                    </div>
                    <!-- End Form -->
                    <!-- Form Temp  -->
                    <div class="p_temp"></div>
                </div>
            </div>
        <!-- END Registration content -->
    <!-- //Below JS is for loading the company information fields from the demand base API -->
    <script type="text/javaScript">
        var productElement = document.getElementById("ACL_Form_CompanyName");
        if (productElement != null && productElement != '' ){
            if(document.getElementById("registerDialog").style.display!='none') {
                var str = "";
                var str1 = "";

                str = " <script>\n"
                        + " (function(d,b,a,s,e){ var t = b.createElement(a), \n"
                        + " fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; \n"
                        + " t.src=('https:'==document.location.protocol ? 'https://' : 'http://') + s; \n"
                        + " fs.parentNode.insertBefore(t, fs); }) \n"
                        + " (window,document,'script','scripts.demandbase.com/nv9gbbyO.min.js','demandbase_js_lib'); \n"
                        + "</scr" + "ipt>";

                document.write(str);
                document.write(str1);
            }
        }
    
</script>
    <!-- //demand base API code ENDs Here -->

    <!-- //Below JS is for generating the date time in the format - DD-MMM-YYYY h:mm:ss -->
	<script type="text/javascript" src="http://i.eindx.com/b2btechleadform/js/moment.min.js">
</script>
                    </div>
                </div><!-- /.modal-content -->
            </div><!-- /.modal-dialog -->
        </div><!-- /.modal -->
        <!-- / dialogue boxes for login registration -->

        <div class="main-content">
                                    <div class="breadcrumb clearfix visible-lg-block">
                <ul class="pull-left">
                                                                        <li><a href="/">Home</a></li>
                                                                                                                             <li><a href="/enterprise-apps">Enterprise Apps</a></li>
                                                                                        </ul>
                                                                            <div class="full-user-cookie hidden">
                        <a
                            href="#"
                            id="follow-topic-follow"
                            class="follow pull-left follow-topic myeweek_hidden"
                            data-id=47103
                        ><span class="icon">+</span>Follow on my eWEEK</a>
                        <a
                            href="#"
                            id="follow-topic-unfollow"
                            class="unfollow pull-left follow-topic myeweek_hidden"
                            data-id=47103
                        ><span class="icon">+</span>UnFollow on my eWEEK</a>
                    </div>
                    <div class="no-qs-cookie hidden">
                        <a
                            href="#"
                            id="follow-topic-login"
                            onClick="showGFrame('login', 'fullmodal', 'recall_followTopic');return false;"
                            class="follow pull-left follow-topic"
                            data-id=47103
                        ><span class="icon">+</span>Follow on my eWEEK</a>
                    </div>
                    <div class="email-only-cookie biz-card-cookie social-user-cookie hidden">
                        <a
                            href="#"
                            id="follow-topic-register"
                            onClick="showGFrame('registrationmodal', 'fullmodal', 'recall_followTopic');return false;"
                            class="follow pull-left follow-topic"
                            data-id=47103
                        ><span class="icon">+</span>Follow on my eWEEK</a>
                    </div>
                    <div class="light-user-cookie hidden">
                        <a
                            href="#"
                            id="follow-topic-upgrade"
                            onClick="showGFrame('upgrademodal', 'fullmodal', 'recall_followTopic');return false;"
                            class="follow pull-left follow-topic"
                            data-id=47103
                        ><span class="icon">+</span>Follow on my eWEEK</a>
                    </div>
                            </div>
            
        <div class="article">
        <div class="row">
            <!-- Article page content -->
            <article class="col-xs-12 col-sm-12 col-md-8 col-lg-9 " itemscope="itemscope" itemtype="http://schema.org/Article">
                                                                    <h1 itemprop="headline" ><span class="ezstring-field">Torvalds Says Open Source Is the Way to Combat Software Complexity</span> </h1>
                                                <div class="social-actions">
                    
        <div class="author-byline">
        By:
                    <span itemprop="author" itemscope itemtype="https://schema.org/Person">
                <span itemprop="name">
                                    <a rel="author" href="/Authors/sean-michael-kerner" title="Posts by Sean Michael Kerner">Sean Michael Kerner</a>
                </span>
            </span>
                |
         <time datetime="2018-08-31" itemprop="datePublished">
            August 31, 2018
        </time>
    </div>

                                                                                                                                                        </div>
                <div class="media-box">
                                    </div>
                                <div class="summary clearfix" itemprop="description">
                    <p>At the Open Source Summit, Linus Torvalds the creator of Linux talked about the Linux development process, security challenges and why Linux will prosper even after he no longer has a guiding hand on the operating system.


</p>
                </div>
                                                <div class="body clearfix" itemprop="articleBody">
                                                                        <div class="article-image visible-sm-block visible-md-block visible-xs-block visible-lg-block" itemprop="image">
                                <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Torvalds-Hohndel-1088x725.jpg?alias=article_hero" alt="Torvalds Hohndel" />
                            </div>
                                            
                                                                <div class="body">
                            <p>VANCOUVER, BC—Linus Torvalds is no longer worried about what happens to Linux if he gets hit by a bus, as he's confident there is a work flow process in place that guarantees the success of Linux. Torvalds, the creator of Linux, shared his views on the future of Linux in a conversation with Dirk Hohndel, Chief Open Source Officer at VMware at the Open Source Summit here Aug. 31</p><p>Torvalds exchanged lively banter with Hohndel on a wide variety of topics ranging from the recent Meltdown and Spectre vulnerabilities, the state of hardware performance, the Linux development process and the future of Linux without Torvalds' guiding hand.</p><p>"What I really worry about is the flow of patches and the workflow is more important than the code," Torvalds said. "If you have the right work flow, code will sort itself out and if a bug happens, we know how to deal with it."</p><p><div id="sl-listings-b2b-olal" data-fallback-tag="%3Clink%20href%3D%22%2F%2Fhqx-impl.com%2Fhqx%2Fmin%2F%3Fr%3Db2b%26f%3D%2Fcss%2FonePaidAssetEzpub.css%22%20type%3D%22text%2Fcss%22%20rel%3D%22stylesheet%22%3E%3Cdiv%20class%3D%22assetNew%22%3E%3Cdiv%20class%3D%22assetNew-icon%22%3E%3Cspan%20class%3D%22assetNew-pdf-button%22%3E%26nbsp%3B%3C%2Fspan%3E%3C%2Fdiv%3E%3Cdiv%20class%3D%22assetNew-title%22%3EIt%27s%20Time%20to%20Rethink%20CRM%3C%2Fdiv%3E%3Cdiv%20class%3D%22assetNew-download%22%3E%3Ca%20href%3D%22http%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%3Fasset%3D219999910%26amp%3Bsrvid%3D96080%26amp%3Bvkey%3D4190310%26amp%3Bio%3D11111%26amp%3Bregorigin%3Dola_listing_widget%26amp%3BlandingURL%3Dhttp%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%26amp%3Bqset%3DCONTACTFORM_HQB%26amp%3BformHQB%3Dy%26amp%3Bdomain%3Dwww.eweek.com%22%20class%3D%22assetNew-download-link%20qsct%22%20rel%3D%22noindex%2C%20nofollow%22%20target%3D%22_blank%22%3EDownload%20Now%3C%2Fa%3E%3C%2Fdiv%3E%3C%2Fdiv%3E"><script src="http://sl.qmp.quinstreet.com/listings?jswrap=y&amp;id=sl-listings-b2b-olal&amp;vertical=b2b&amp;webSiteName=www.ezpublish.com&amp;webPageUri=/onelinepayedassetlisting.html&amp;portalServiceCode=B2B_PRODUCT_PLATFORM_OS_LINUX,B2B_PRODUCT_SERVERS_SERVER_OPERATING_SYSTEMS_LINUX_SERVER_OPERATTING_SYSTEM,B2B_PRODUCT_DEVELOPMENT_OPEN_SOURCE_SOFTWARE_DEVELOPMENT,B2B_AUDIENCE_PURCHASE_STAGE_AWARENESS&amp;templateName=bootstrapArticleMiddlePosition_A&amp;widgetInstanceKey=24657610&amp;affiliateKey=72179444&amp;tag=204377811&amp;customParams=%7B%22landingURL%22%3A%22http%3A%5C%2F%5C%2Fo1.qnsr.com%5C%2Fcgi%5C%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%5C%2F%5C%2Fassetform.eweek.com%5C%2Fcontroller%22%2C%22qset%22%3A%22CONTACTFORM_HQB%22%2C%22formHQB%22%3A%22y%22%2C%22domain%22%3A%22www.eweek.com%22%7D">
</script></div><div style="clear:both;"></div></p><div class="further-reading"><h4>Further reading</h4>

<ul>
            <li>
            <a href="/enterprise-apps/microsoft-bringing-google-id-log-ins-to-azure-active-directory">
                                                                    Azure AD B2B Collaboration Supports Google IDs            </a>
        </li>
            <li>
            <a href="/enterprise-apps/microsoft-s-power-bi-embedded-gets-multi-geo-support-preview-feature">
                                                                    Power BI Embedded Gets Multi-Geo Support            </a>
        </li>
    </ul>
</div><p>In reference to the Meltdown and Spectre security vulnerabilities that first emerged in Jaunary, Torvalds said it feels 'less fair" when the Linux kernel has to fix someone else's issues. Torvalds also is not a fan of keeping vulnerabilities secret as it impacts his development work flow. With the Spectre and Meltdown vulnerabilities there has been a need to keep information private, which means that kernel developers have had to keep some things private and have not been able to do everything in the open as is the usual process.</p><p>During the conversation, Hohndel also asked Torvalds if he knew when the next set of Meltdown and Spectre issues would be patched in Linux. </p><p>"I don't know what the schedule is and if i knew I wouldn't be able to tell you," Torvalds quipped. </p><p>That said, Torvalds noted that the Meltdown and Spectre bugs have become increasingly esoteric lately. He added that Intel as well as others in the IT industry are very aware of the issues and he's hopeful that going forward there will be fewer Meltdown and Spectre issues.</p><a name="eztoc_1_1_1" id="eztoc_1_1_1"></a><h3>Quantum Computing</h3><p>While there is lots of hype in the industry about the potential for Quantum computing, Torvalds is not a believer.</p><p>"I am a huge unbeliever in that thing (quanutm computing)," Torvalds said. "I will be long dead by the time people can prove me wrong."</p><p>Torvalds also doesn't see computer performance accelerating as quickly as it once did and he also doesn't believe that Moore's Law is still a reality. With Moore's Law the basic idea is that computing power doubles every two years, which Torvalds said really isn't happening anymore.</p><p>"Performance is not really doubling every two years and that's good," Torvalds said. "It means we'll maybe go back to the time when you cared more about performance on the software side and you had to be more careful and couldn't just rely on hardware getting better."</p><a name="eztoc_2_1_1" id="eztoc_2_1_1"></a><h3>On Growing a Developer Community</h3><p>Torvalds also commented on his role as the maintainer of Linux and what can or should be done to grow a development community.</p><p>"As the maintainer of a project your job is to make sure the project works as well as you can make it work and that you are responsive to the developers you have," Torvalds said. "It's the—'if you build they will come model'—you need to do so well that developers come and look for you."</p><p>Torvalds also admitted that he doesn't know every line of code in the Linux kernel at this point and that's not necessarily a bad thing.</p><p>"Nobody knows the whole kernel anymore," Torvalds said. "Having looked at patches for many years, I know the big picture of all the areas in the kernel and I can look at a patch and know if it's right or wrong."</p><p>Torvalds now relies on a group of maintainers and sub-maintainers to handle the specific areas of the Linux kernel. As such he noted that if he were to be hit by a bus, Linux would continue, because it is the maintainers that are doing all the heavy lifting of Linux development today.</p><p>The need for multiple developers to maintain different parts of the kernel is a function of the kernel's size. The size of the kernel also leads to complexity, which is where Torvalds said that the open-source model is core to Linux's success. </p><p>"When you have complexity you can't manage it in a closed environment,  you need to have the people that actually find problems and give them the ability to get involved and help you to fix them," Torvalds said. "Its a complicated world and the only way to deal with complexity is the open exchange of ideas."</p><p><em>Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.</em></p>

                        </div>
                                        
                </div>
                <div class="dfp_imu visible-xs-block">
                                        <script>
                        if (myQSPfm == "mob") {
                            document.write("<!-- QS-AD: p1-imu start -->");
                            var t = displayDFPTag("p1-imu");
                            document.write(t);
                            document.write("<!-- QS-AD: p1-imu end -->");
                        }
                    
</script>
                </div>

                                                    <nav>
                        <ul class="story-nav">
                                                            <li>
                                    <a href="/enterprise-apps/vmware-vcloud-director-ready-to-run-in-ibm-hybrid-cloud">
                                        <span aria-hidden="true" class="glyphicon glyphicon-menu-left"></span>
                                        <span class="action">Previous Story</span>
                                    </a>
                                </li>
                                <li>
                                    <span class="action">Previous</span>
                                    <a href="/enterprise-apps/vmware-vcloud-director-ready-to-run-in-ibm-hybrid-cloud">
                                        VMware vCloud Director Ready to Run in IBM Hybrid Cloud                                    </a>
                                </li>
                                                        <li class="separator"></li>
                                                            <li>
                                    <span class="action">Next</span>
                                    <a href="/enterprise-apps/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                        IT Science Case Study: How Walmart Embraced Test Automation,...                                    </a>
                                </li>
                                <li>
                                    <a href="/enterprise-apps/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                        <span class="action">Next Story</span>
                                        <span aria-hidden="true" class="glyphicon glyphicon-menu-right"></span>
                                    </a>
                                </li>
                                                    </ul>
                    </nav>
                                                <div class="widget-related-content visible-sm-block visible-md-block visible-xs-block">
                </div>
                                                                                                                                                                                                                                                                                                    
                                                                            
                        
                                                                            
                                                                                                                                                                                                                                
                        
                                                    <div class="author-highlight clearfix">
                                                                <div class="image">
                                    <img class="responsive" src="/imagesvr_ez/b2bezp/2016/11/48993_7_Sean%20Michael%20Kerner_standard.gif?alias=author_bio" alt="Sean Michael Kerner" />
                                </div>
                                                                <div class="bio">
                                    <h3>Sean Michael Kerner</h3>
                                                                                                            <p>Sean Michael Kerner is an Internet consultant, strategist, and contributor to several leading IT business web sites.

</p>
                                </div>
                                <span itemprop="author" itemscope itemtype="https://schema.org/Person">
                                    <span itemprop="name">
                                        <a
                                            href="/Authors/sean-michael-kerner"
                                            title="Post by Sean Michael Kerner"
                                            rel="author"
                                            class="viewBio-button"
                                        >View full bio<span class="view-bio glyphicon glyphicon-menu-right"></span></a>
                                    </span>
                                </span>
                                <div class="social clearfix row">
                                    <div class="pull-right">
                                        <div class="connect-combo">
                                            <span class="connect">Connect with Sean:</span>
                                        </div>
                                                                                <div class="authorFollow">
                                            <div class="full-user-cookie hidden">
                                                <a
                                                    href="#"
                                                    id="follow-author-follow"
                                                    class="follow pull-left follow-author myeweek_hidden"
                                                    data-id=48993
                                                ><span class="icon">+</span>Follow on my eWEEK</a>
                                                <a
                                                    href="#"
                                                    id="follow-author-unfollow"
                                                    class="unfollow pull-left follow-author myeweek_hidden"
                                                    data-id=48993
                                                ><span class="icon">+</span>UnFollow on my eWEEK</a>
                                            </div>
                                            <div class="no-qs-cookie hidden" style="padding:0px;">
                                                <a
                                                    href="#"
                                                    id="follow-author-login"
                                                    onClick="showGFrame('login', 'fullmodal', 'recall_followAuthor');return false;"
                                                    class="follow pull-left follow-author"
                                                    data-id=48993
                                                ><span class="icon">+</span>Follow on my eWEEK</a>
                                            </div>
                                            <div class="email-only-cookie biz-card-cookie social-user-cookie hidden" style="padding:0px;">
                                                <a
                                                    href="#"
                                                    id="follow-author-register"
                                                    onClick="showGFrame('registrationmodal', 'fullmodal', 'recall_followAuthor');return false;"
                                                    class="follow pull-left follow-author"
                                                    data-id=48993
                                                ><span class="icon">+</span>Follow on my eWEEK</a>
                                            </div>
                                            <div class="light-user-cookie hidden" style="padding:0px;">
                                                <a
                                                    href="#"
                                                    id="follow-author-upgrade"
                                                    onClick="showGFrame('upgrademodal', 'fullmodal', 'recall_followAuthor');return false;"
                                                    class="follow pull-left follow-author"
                                                    data-id=48993
                                                ><span class="icon">+</span>Follow on my eWEEK</a>
                                            </div>
                                        </div>
                                                                            </div>
                                </div>
                            </div>
                                            
                
            </article><!-- content -->
                        <div class="hidden-xs hidden-sm col-md-4 col-lg-3 decrease-padding-left ">
                                                                                                                
<!-- personalization-widget -->
<div class="visible-lg-block">
    <div class="row">
        <div class="col-sm-12">
            <div class="personalization-widget-wrapper">
                <div class="personalization-widget-box no-qs-cookie hidden">
                    <!-- default-nocookie-widget -->
                    <div id="personalization-no-qs-cookie">
                        <form id="newsletterSubscribForm" method="post" name="newsletterSubscribForm">
                            <div class="newsletter-icon"></div>
                            <div class="newsletter-header">
                                <div class="newsletter-arrow floatL"></div>
                                <div class="newsletter-header-text floatL">
                                    <div class="subscribe-text">Subscribe <span class="newsletter-text">to</span></div>
                                    <div class="floatL newsletter-text">eWEEK Editor's Pick</div>
                                </div>
                            </div>
                            <div id="nlsubscribeMessage" class="error"></div>
                            <div class="newsletter-form" id="newsletter-form">
                                <div class="floatL">
                                    <input type="text" id="nl_email" name="nl_email" maxlength="255" onblur="if (this.value == '') {
                                                this.value = 'Enter Email Address';
                                            }" onfocus="if (this.value == 'Enter Email Address') {
                                                        this.value = '';
                                                    }" value="Enter Email Address">
                                </div>
                                <div class="floatL">
                                    <input type="button" name="btnSubscribe" id="nl_submit_button" value="GO >">
                                </div>
                            </div>
                            <div class="login-form center-text">
                                Or <span class="submit_button" onclick="showGFrame('login', 'full');return false;">Log in</span>
                            </div>
                            <div class="newsletter-more">
                                <a id="morenewsletters" data-placement="left" data-toggle="popover" data-container="body" data-placement="left" type="button" data-html="true">Click for more newsletters</a>
                            </div>
                            <div class="myeweek_vspace"></div>
                            <div id="listContent" class="hide orig_listContent">
                                <ul class="list-group no_border nlcheckbox">
    <li class="list-group-item no_border nlcheckbox"">
    <input type="checkbox" id="subscribe_1" name="subscribe" value="9310">
    <label for="subscribe_1">eWEEK Editor's Pick</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_2" name="subscribe" value="10110">
        <label for="subscribe_2">News &amp; Views</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_3" name="subscribe" value="8710">
        <label for="subscribe_3">Cloud Computing</label></li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_4" name="subscribe" value="10710">
        <label for="subscribe_4">Mobile and Wireless Update</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_5" name="subscribe" value="8810">
        <label for="subscribe_5">Best of eWEEK</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_6" name="subscribe" value="10810">
        <label for="subscribe_6">eWEEK Sunday Brunch</label></li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_7" name="subscribe" value="8910">
        <label for="subscribe_7">eCareers Smart Moves</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_8" name="subscribe" value="9010">
        <label for="subscribe_8">Enterprise Applications Topic Center Update</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_9" name="subscribe" value="9110">
        <label for="subscribe_9">Enterprise IT Advantage</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_10" name="subscribe" value="17210">
        <label for="subscribe_10">eWEEK Whitepaper Spotlight</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_11" name="subscribe" value="10210">
        <label for="subscribe_11">eWEEK Labs</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_12" name="subscribe" value="9210">
        <label for="subscribe_12">eWEEK Enterprise Update</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_13" name="subscribe" value="10410">
        <label for="subscribe_13">eWEEK Storage Report</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_14" name="subscribe" value="9510">
        <label for="subscribe_14">Industry Center Update : Finance</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_15" name="subscribe" value="9610">
        <label for="subscribe_15">Industry Center Update : Government</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_16" name="subscribe" value="9710">
        <label for="subscribe_16">Industry Center Update : Health Care</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_17" name="subscribe" value="9810">
        <label for="subscribe_17">Infrastructure Topic Center Update</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_18" name="subscribe" value="9910">
        <label for="subscribe_18">Linux &amp; Open Source Topic Center Update</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_19" name="subscribe" value="10010">
        <label for="subscribe_19">Mid-Market Solutions</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_20" name="subscribe" value="10310">
        <label for="subscribe_20">Securing the Enterprise</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_21" name="subscribe" value="10510">
        <label for="subscribe_21">VoIP Topic Center Update</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_22" name="subscribe" value="10610">
        <label for="subscribe_22">What's Hot Now</label>
    </li>
    <li class="list-group-item no_border nlcheckbox">
        <input type="checkbox" id="subscribe_23" name="subscribe" value="9410">
        <label for="subscribe_23">eWEEKend</label>
    </li>
</ul>
                            </div>
                        </form>
                            <p style="padding: 8px 12px 0 12px;text-align: left;font-size: 13px;">By submitting your information, you agree that eweek.com may send you eWEEK offers via email, phone and text message, as well as email offers about other products and services that eWEEK believes may be of interest to you. eWEEK will process your information in accordance with the <a style="text-decoration: underline;" href="/privacy">Quinstreet Privacy Policy</a>.</p>
                    </div>
                    <!-- END default-nocookie-widget -->
                    <!-- email/bizcard-exists-widget -->
                    <div id="personalization-email-exists" class="myeweek_hidden">
                        <div class="header-text">We ran into a problem</div>
                        <div class="regular-text myeweek_padding_sm">We already have your email address on file. Please use the "<a href="/myeweek/forgotpassword">Forgot your password?</a>" link to create a password, validate your email and login.</div>
                        <div class="login-more light_blue center-text">
                            <a href="/myeweek/forgotpassword">Forgot password?</a> | <a href="/myeweek/register">Create New Account</a>
                        </div>
                    </div>
                    <!-- END email/bizcard-exists-widget -->
                    <!-- social-exists-widget -->
                    <div id="personalization-social-exists" class="myeweek_hidden">
                        <div class="header-text">We ran into a problem</div>
                        <div class="regular-text myeweek_padding_sm">We already have your email address on file as a Social Account. Please <a href="#" onclick="showGFrame('login', 'full');return false;">log in</a> with your current Social Account or click "<a href="/myeweek/forgotpassword">Forgot your password?</a>" to validate your email and login.</div>
                        <div class="login-more light_blue center-text">
                            <a href="/myeweek/forgotpassword">Forgot password?</a> | <a href="/myeweek/register">Create New Account</a>
                        </div>
                    </div>
                    <!-- END social-exists-widget -->
                    <!-- light/full-exists-widget -->
                    <div id="personalization-light-exists" class="myeweek_hidden">
                        <div class="header-text">We ran into a problem</div>
                        <div class="regular-text myeweek_padding_sm">We already have an account with that email address. Please log in to edit your information.</div>
                        <div class="center-text">
                            <span class="check-icon"></span>
                            <span class="regular-text light_blue personalization-email"></span>
                            <div id="personalizeloginMessage" class="error"></div>
                            <form id="personalization_login">
                                <input type="hidden" id="login_email" maxlength="255" value="">
                                <input type="hidden" id="login_newsletterkeys" value="">
                                <input type="text" id="login_password" class="input_text" maxlength="255" 
                                onblur="if (this.value == '') {
                                    this.value = 'Enter Password';this.type = 'text';
                                }" onfocus="if (this.value == 'Enter Password') {
                                    this.value = '';this.type = 'password';
                                }" value="Enter Password">
                                <div class="email-exists-section center-text">
                                    <input type="submit" class="submit_button" value="Log In" id="login_submit_button">
                                </div>
                            </form>
                            <div class="login-more light_blue center-text">
                                <a href="/myeweek/forgotpassword">Forgot password?</a> | <a href="/myeweek/register">Create New Account</a>
                            </div>
                        </div>
                    </div>
                    <!-- END light/full-exists-widget -->
                    <div class="myeweek_vspace"></div>
                </div>
                <!-- END default-nocookie-widget -->
                <!-- email-only|biz-card|social-widget -->
                <div id="email-only-welcomeback" class="personalization-widget-box email-only-cookie biz-card-cookie social-user-cookie hidden">
                    <div class="welcome_back-email">
                        <div class="header-text">Welcome back!</div>
                        <div class="regular-text">You're currently subscribed to some eWEEK features and just need to create a username and password to complete your registration<span id="personalize_EditorsPick_signup"> and sign up for our eWEEK Editor's Pick newsletter.</span></div>
                    </div>

                    <div class="ty_for_subscribing-email myeweek_hidden">
                        <div class="header-text">Thanks for subscribing!</div>
                        <div class="regular-text">To complete your registration, create a username and password for My eWEEK:</div>
                    </div>

                    <div id="uptolightMessage" class="error"></div>
                    <div id="personalize_EditorsPick_wrapper" class="center-text">
                        <label class="Form_radiolabel radio-inline">
                            <input id="personalize_EditorsPick" type="checkbox" checked value="9310" name="personalize_EditorsPick">
                            Subscribe to eWEEK Editor's Pick
                        </label>
                    </div>
                    <div id="email-update" class="center-text">
                        <span class="check-icon"></span>
                        <span id="email-only-email" class="regular-text light_blue personalization-email"></span>
                        <span class="edit-icon" data-toggle="modal" data-target="#confirm-delete"></span>
                    </div>

                    <form id="email-only_upgrade">
                        <div class="upgrade-form">
                            <div class="floatL">
                                <input type="hidden" id="return_user_upgrade_email" class="input_text" maxlength="255" value="">
                                <input type="text" id="return_user_create_username" class="input_text" maxlength="255" 
                                onblur="if (this.value == '') {
                                    this.value = 'Enter Username';
                                }" onfocus="if (this.value == 'Enter Username') {
                                    this.value = '';
                                }" value="Enter Username">
                            </div>
                            <div class="floatL">
                                <input type="text" id="return_user_login_password" class="input_text" maxlength="255" 
                                onblur="if (this.value == '') {
                                    this.value = 'Enter Password';this.type = 'text';
                                }" onfocus="if (this.value == 'Enter Password') {
                                    this.value = '';this.type = 'password';
                                }" value="Enter Password">
                            </div>
                        </div>
                        <div class="center-text">
                            <input type="submit" class="submit_button" value="Submit >" id="upgrade_submit_button">
                        </div>
                        <div class="myeweek_vspace"></div>
                    </form>
                </div>
                <!--Modal Box -->
                <div class="modal fade" id="confirm-delete" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true">
                    <div class="modal-dialog modal-sm">
                        <div class="modal-content">
                            <div class="modal-body">
                                Are you sure you want to change the email address we have on record for you?
                            </div>
                            <div class="modal-footer">
                                <a class="btn btn-ok">Confirm</a> |
                                <a class="btn" data-dismiss="modal">Cancel</a>
                            </div>
                        </div>
                    </div>
                </div>
                <!--Modal End -->
                <!-- light-user-widget -->
                <div class="personalization-widget-box light-user-cookie hidden">
                    <div class="header-text">Welcome back!</div>
                    <div class="regular-text">You're currently subscribed to some eWEEK features, but just need to complete your registration to enjoy our full range of site personalization and great email newsletters.
                    </div>
                    <div class="light-user-email">
                        <span class="check-icon"></span>
                        <span id="light_returning_user" class="regular-text light_blue personalization-email"></span>
                    </div>
                    <div class="text-center">
                        <a href="/myeweek/information" class="submit_button">Go ></a>
                    </div>
                    <div class="myeweek_vspace"></div>
                </div>
                <!-- END light-user-widget -->
                <!-- full-user-widget -->
                <div class="personalization-widget-box full-user-cookie hidden">
                    <!-- full-user-w/o personalization -->
                    <div id="not-personalized-full" class="myeweek_hidden">
                        <div class="header-text">Welcome back!</div>
                        <div class="regular-text">Personalize your eWEEK experience by following topics that interest you.  You'll see relevant content on your My eWEEK page.</div>
                        <form id="PersonalisedFollowForm" method="post">
                            <div id="topic-list">
                                <div class="checkbox">
                                    <label><input class="personalized_topics" type="checkbox" data-id="51109" value="51109" checked><strong>Big Data and Analytics</strong></label>
                                </div>
                                <div class="checkbox">
                                    <label><input class="personalized_topics" type="checkbox" data-id="47113" value="47113" checked><strong>Cloud</strong></label>
                                </div>
                                <div class="checkbox">
                                    <label><input class="personalized_topics" type="checkbox" data-id="47087" value="47087" checked><strong>Networking</strong></label>
                                </div>
                                <div class="checkbox">
                                    <label><input class="personalized_topics" type="checkbox" data-id="47091" value="47091" checked><strong>Mobile</strong></label>
                                </div>
                            </div>
                            <div class="center-text">
                                <input type="submit" class="submit_button" value="Follow >" id="personalization_follow">
                            </div>
                            <div class="center-text">
                                <div id="personalization_follow_error" class="text-danger"></div>
                            </div>
                        </form>
                        <div class="mysubscription-text">
                            <a href="/myeweek/subscriptions">See all personalization options ></a>
                        </div>
                        <div class="myeweek_vspace"></div>
                    </div>
                    <!-- end full-user-w/o personalization -->
                    <!-- full-user-w/ personalization -->
                    <div id="personalized-full" class="myeweek_hidden">
                        <div class="header-text">Latest in My eWEEK</div>
                        <div id="personalization_content" class="myeweek_hidden"></div>
                        <div class="center-text top-space">
                            <a href="/myeweek" id="personalization_gomyeweek" class="btn btn-primary" role="button">Go to My eWEEK ></a>
                        </div>
                        <!--<div class="mysubscription-text">
                            <a href="/myeweek/subscriptions">Change subscription ></a>
                        </div>-->
                        <div class="myeweek_vspace"></div>
                    </div>
                    <!-- end full-user-w/ personalization -->
                </div>
                <!-- END full-user-widget -->
            </div>
        </div>
    </div>
    <div class="myeweek_vspace"></div>
    <div class="myeweek_vspace"></div>
</div>
<!-- END personalization-widget -->

                                            <script>
                    if (myQSPfm == "des" || myQSPfm == "tab-l") {
                        document.write("<div class=\"dfp_imu visible-lg-block visible-md-block\" >");
                        document.write("<!-- QS-AD: p1-imu start -->");
                        var t = displayDFPTag("p1-imu");
                        document.write(t);
                        document.write("<!-- QS-AD: p1-imu end -->");
                        document.write("</div>");
                    }
                
</script>
                                                        
<div class="widget-editors-choice visible-lg-block">
    <h3>Editor's Choice</h3>
        <div class="lead-item">
        <div class="image">
            <div class="background">
                                <a href="http://www.eweek.com/mobile/opposition-seems-muted-in-statements-to-fcc-on-t-mobile-sprint-merger">
                    <img class="responsive" src="/imagesvr_ez/b2bezp/2017/11/sprint_t-mobile.png?alias=slideshow_preview" alt="Sprint T-Mobile" />
                </a>
            </div>
            <a href="http://www.eweek.com/mobile/opposition-seems-muted-in-statements-to-fcc-on-t-mobile-sprint-merger" class="back-overlay"><div class="gradient-overlay"></div></a>
            <a href="http://www.eweek.com/mobile/opposition-seems-muted-in-statements-to-fcc-on-t-mobile-sprint-merger" class="front-overlay">
                Opposition Seems Muted in Statements to FCC on T-Mobile-Sprint...            </a>
        </div>
        <div class="author-byline">
                            By:
                <a href="/Authors/wayne-rash">
                    Wayne Rash
                </a>
                                                    |
                    <time datetime="2018-08-31">
                        August 31, 2018
                    </time>
                                    </div>
    </div>
        <ul class="clearfix">
                                            <li class="clearfix">
                <div class="image">
                    <a href="http://www.eweek.com/development/it-science-case-study-how-walmart-embraced-test-automation-open-source">
                                                                                                                <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Walmart.ecommerce.jpg?alias=carousel_regular" alt="Walmart.labs" />
                                                                        </a>
                </div>
                <div class="item">
                    <a href="http://www.eweek.com/development/it-science-case-study-how-walmart-embraced-test-automation-open-source">IT Science Case Study: How Walmart Embraced Test Automation,...</a>
                </div>
            </li>
                                                        <li class="clearfix">
                <div class="image">
                    <a href="http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity">
                                                                                                                <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Torvalds-Hohndel-1088x725.jpg?alias=carousel_regular" alt="Torvalds Hohndel" />
                                                                        </a>
                </div>
                <div class="item">
                    <a href="http://www.eweek.com/enterprise-apps/torvalds-says-open-source-is-the-way-to-combat-software-complexity">Torvalds Says Open Source Is the Way to Combat Software...</a>
                </div>
            </li>
                                                        <li class="clearfix">
                <div class="image">
                    <a href="http://www.eweek.com/it-management/how-to-choose-the-proper-analytics-tools-for-an-enterprise">
                                                                                                                <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Data.analytics.JPG?alias=carousel_regular" alt="Data.analytics" />
                                                                        </a>
                </div>
                <div class="item">
                    <a href="http://www.eweek.com/it-management/how-to-choose-the-proper-analytics-tools-for-an-enterprise">How to Choose the Proper Analytics Tools for an Enterprise</a>
                </div>
            </li>
                        </ul>
</div>

                                                                                                                                                    <div class="widget-video-promotion hide visible-lg-block">
    <h3>Related video</h3>
    <div class="dynamic-widget-items" data-dynamic-items-limit="1">
                    <div class="item" data-widget-item-id="1052889">
                                     <div class="image">
                         <a href="/enterprise-apps/the-linux-foundation-set-to-improve-open-source-code-security">
                             <div class="play-overlay"></div>
                             <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/Jim-Zemlin-OSS2018-1088x725.png?alias=list_medium" alt="Jim Zemlin OSS 2018" />
                         </a>
                     </div>
                                  <a class="detail" href="/enterprise-apps/the-linux-foundation-set-to-improve-open-source-code-security">The Linux Foundation Set to Improve Open-Source Code...</a>
                                                   <p>VIDEO: At the Open Source Summit, Jim Zemlin, Executive Director of the Linux Foundation explains...</p>
            </div>
                    <div class="item" data-widget-item-id="1052217">
                                     <div class="image">
                         <a href="/enterprise-apps/skype-classic-fans-change-microsoft-s-mind-about-ending-support">
                             <div class="play-overlay"></div>
                             <img class="responsive" src="/imagesvr_ez/b2bezp/2018/08/eweek_8.9.18.jpg?alias=list_medium" alt="Daily Tech Briefing Aug. 9, 2018" />
                         </a>
                     </div>
                                  <a class="detail" href="/enterprise-apps/skype-classic-fans-change-microsoft-s-mind-about-ending-support">Skype Classic Fans Change Microsoft&#039;s Mind About Ending...</a>
                                                   <p>DAILY VIDEO: Microsoft listens to customers, will continue Skype Classic support, and Toshiba...</p>
            </div>
            </div>
    <a
         class="view-all"
         href="/video/featured"
     >View all</a>
</div>

                                                        <!-- WhitePaper Listing -->
<div class="qmpContainer visible-lg-block">
    <div id="widget-title">
        <strong>Top White Papers and Webcasts </strong>
    </div>
    <div class="caret whitepaper-caret"></div>
    <div class="cachedWidget">
        <ul id="sl-listings-b2b" class="listing"
                data-fallback-tag="%3Clink%20href%3D%22%2F%2Fhqx-impl.com%2Fhqx%2Fmin%2F%3Fr%3Db2b%26f%3D%2Fcss%2Fqmp%2Fezpub_qmp_default.css%22%20type%3D%22text%2Fcss%22%20rel%3D%22stylesheet%22%3E%3Cli%20class%3D%22asset%22%3E%20%20%20%20%20%3Cdiv%20class%3D%22asset-first%22%3E%20%20%20%20%20%20%20%20%20%3Cdiv%20class%3D%22asset-col-left%22%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%3Cdiv%20class%3D%22asset-image%22%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3Ca%20class%3D%22qsct%22%20href%3D%22http%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%3Fasset%3D219999910%26amp%3Bsrvid%3D96080%26amp%3Bvkey%3D4190310%26amp%3Bio%3D11111%26amp%3Bregorigin%3Dlisting_widget%26amp%3BlandingURL%3Dhttp%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%26amp%3Bqset%3DCONTACTFORM_HQB%26amp%3BformHQB%3Dy%26amp%3Bdomain%3Dwww.eweek.com%22%20target%3D%22_blank%22%20rel%3D%22noindex%2C%20nofollow%22%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3Cimg%20src%3D%22%2Fimagesvr_ce%2F7635%2Fquinstreet-0162-its_time_to_rethink_crm-100.gif%22%20class%3D%22assetthumb%22%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3C%2Fa%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%3C%2Fdiv%3E%20%20%20%20%20%20%20%20%20%3C%2Fdiv%3E%20%20%20%20%20%20%20%20%20%3Cdiv%20class%3D%22asset-col-right%22%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%3Cdiv%20class%3D%22asset-title%22%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3Ca%20class%3D%22qsct%22%20href%3D%22http%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%3Fasset%3D219999910%26amp%3Bsrvid%3D96080%26amp%3Bvkey%3D4190310%26amp%3Bio%3D11111%26amp%3Bregorigin%3Dlisting_widget%26amp%3BlandingURL%3Dhttp%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%26amp%3Bqset%3DCONTACTFORM_HQB%26amp%3BformHQB%3Dy%26amp%3Bdomain%3Dwww.eweek.com%22%20target%3D%22_blank%22%20rel%3D%22noindex%2C%20nofollow%22%3EIt%27s%20Time%20to%20Rethink%20CRM%3C%2Fa%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%3C%2Fdiv%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%3Cdiv%20class%3D%22asset-download-btn%22%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3Ca%20class%3D%22btn%20btn-warning%20btn-block%20btn-orange%22%20href%3D%22http%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%3Fasset%3D219999910%26amp%3Bsrvid%3D96080%26amp%3Bvkey%3D4190310%26amp%3Bio%3D11111%26amp%3Bregorigin%3Dlisting_widget%26amp%3BlandingURL%3Dhttp%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%26amp%3Bqset%3DCONTACTFORM_HQB%26amp%3BformHQB%3Dy%26amp%3Bdomain%3Dwww.eweek.com%22%20target%3D%22_blank%22%20rel%3D%22noindex%2C%20nofollow%22%3ERegister%20Now%3C%2Fa%3E%20%20%20%20%20%20%20%20%20%20%20%20%20%3C%2Fdiv%3E%20%20%20%20%20%20%20%20%20%3C%2Fdiv%3E%20%20%20%20%20%20%20%20%20%3Cdiv%20class%3D%22clearfix%22%3E%3C%2Fdiv%3E%20%20%20%20%20%3C%2Fdiv%3E%20%3C%2Fli%3E%20%3Cli%20class%3D%22sub-header-text%22%3EAdditional%20Downloads%3C%2Fli%3E%20%20%20%20%20%20%20%20%3Cli%20class%3D%22asset-listing%22%20style%3D%22padding-bottom%3A0%3B%22%3E%20%20%20%20%20%3Cdiv%20class%3D%22asset-title-link%22%3E%20%20%20%20%20%20%20%20%20%3Ca%20class%3D%22qsct%22%20href%3D%22http%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%3Fasset%3D220012510%26amp%3Bsrvid%3D95880%26amp%3Bvkey%3D4190310%26amp%3Bio%3D11111%26amp%3Bregorigin%3Dlisting_widget%26amp%3BlandingURL%3Dhttp%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%26amp%3Bqset%3DCONTACTFORM_HQB%26amp%3BformHQB%3Dy%26amp%3Bdomain%3Dwww.eweek.com%22%20target%3D%22_blank%22%20rel%3D%22noindex%2C%20nofollow%22%3EReady%20Your%20Enterprise%20for%20the%20API%20Revolution%3C%2Fa%3E%20%20%20%20%20%3C%2Fdiv%3E%20%3C%2Fli%3E%20%20%20%20%20%20%20%3Cli%20class%3D%22asset-listing%22%3E%20%20%20%20%20%3Cdiv%20class%3D%22asset-title-link%22%3E%20%20%20%20%20%20%20%20%20%3Ca%20class%3D%22qsct%22%20href%3D%22http%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%3Fasset%3D220032010%26amp%3Bsrvid%3D96100%26amp%3Bvkey%3D4190310%26amp%3Bio%3D11111%26amp%3Bregorigin%3Dlisting_widget%26amp%3BlandingURL%3Dhttp%3A%2F%2Fo1.qnsr.com%2Fcgi%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%2F%2Fassetform.eweek.com%2Fcontroller%26amp%3Bqset%3DCONTACTFORM_HQB%26amp%3BformHQB%3Dy%26amp%3Bdomain%3Dwww.eweek.com%22%20target%3D%22_blank%22%20rel%3D%22noindex%2C%20nofollow%22%3EPlanning%20a%20Successful%20ERP%20Implementation%3C%2Fa%3E%20%20%20%20%20%3C%2Fdiv%3E%20%3C%2Fli%3E">
                            <script type="text/javascript"  src="http://sl.qmp.quinstreet.com/listings?jswrap=y&id=sl-listings-b2b&vertical=b2b&webSiteName=www.ezpublish.com&webPageUri=/featuredqmplisting.html&portalServiceCode=B2B_PRODUCT_PLATFORM_OS_LINUX,B2B_PRODUCT_SERVERS_SERVER_OPERATING_SYSTEMS_LINUX_SERVER_OPERATTING_SYSTEM,B2B_PRODUCT_DEVELOPMENT_OPEN_SOURCE_SOFTWARE_DEVELOPMENT,B2B_AUDIENCE_PURCHASE_STAGE_AWARENESS&templateName=ezpub_featured_listing&widgetInstanceKey=24657510&affiliateKey=72179444&tag=204377811&customParams=%7B%22landingURL%22%3A%22http%3A%5C%2F%5C%2Fo1.qnsr.com%5C%2Fcgi%5C%2Fr%3F%3Bn%3D203%3Bc%3D1395307%3Bs%3D14821%3Bx%3D7936%3Bf%3D201308291444490%3Bu%3Dj%3Bz%3DTIMESTAMP%3Bk%3Dhttp%3A%5C%2F%5C%2Fassetform.eweek.com%5C%2Fcontroller%22%2C%22qset%22%3A%22CONTACTFORM_HQB%22%2C%22formHQB%22%3A%22y%22%2C%22domain%22%3A%22www.eweek.com%22%7D">
</script>
                    </ul>
    </div>
</div>

                                            <script>
                    if (myQSPfm == "des") {
                        document.write("<div class=\"dfp_imu visible-lg-block\" >");
                        document.write("<!-- QS-AD: p2-imu start -->");
                        var t = displayDFPTag("p2-imu");
                        document.write(t);
                        document.write("<!-- QS-AD: p2-imu end -->");
                        document.write("</div>");
                    }
                
</script>
            
                            </div>
                    </div>
    </div>
        <script>
        if (myQSPfm == "tab-p") {
            document.write("<div class=\"visible-sm-block\">");
            document.write("<!-- QS-AD: pf start -->");
            var t = displayDFPTag("pf");
            t = "<div id=\"dfp_pf\"><div class=\"dfp_pf\">" + t + "</div></div>";
            document.write(t);
            document.write("<style type=\"text/css\">body{padding-bottom:110px;}</style>");
            document.write("<!-- QS-AD: pf end -->");
            document.write("</div>");
        }
    
</script>
        </div><!-- /.main-content -->
    </div><!-- /.container -->

        <div>
                            <script>
            if (myQSPfm == "des") {
                document.write("<div class=\"dfp_lb visible-lg-block\" >");
                document.write("<!-- QS-AD: p2-lb start -->");
                var t = displayDFPTag("p2-lb");
                document.write(t);
                document.write("<!-- QS-AD: p2-lb end -->");
                document.write("</div>");
            }
        
</script>
        </div>

    <div class="footer-wrapper">
        



<footer class="footer-main container">
    <div class="footer-one clearfix">
        <div class="footer-links">
            <div>
                <br>
                <a href="/"><img src="/bundles/eweekbase/images/footer_logo.png" alt="eWEEK - Enterprise IT Technology News, Opinion and Reviews"></a><br>
                <br>
                                        <a href="/contact-us.html">Contact Us</a>
                     | <a href="/about-us.html">About eWeek</a>
                     | <a href="/sitemap.html">Sitemap</a>
    
                <br>
            </div>
        </div>
    </div>
    <div class="footer-two">
        <div id="footer-social-icon">
        </div>
        <div class="footer-links">
            <div>
                Property of QuinStreet Enterprise.<br>
                <a href="//www.eweek.com/terms">Terms of Service</a> | <a href="//www.eweek.com/licensing">Licensing &amp; Reprints</a> | <a href="//www.eweek.com/privacy">Privacy Policy</a> | <a href="//www.quinstreetenterprise.com/advertise">Advertise</a><br>
                <br>
                Copyright 2018 QuinStreet Inc. All Rights Reserved
            </div>
        </div>
    
   
<style type="text/css">
#sitePrivacyModal{display: none;}   
#sitePrivacyModal .privacy-modal {display: none;position: fixed;z-index: 10000;left: 0;top: 0;overflow: auto;}
#sitePrivacyModal .privacy-modal-content {background-color: #efefef;position: fixed;bottom: 0;width: 32%;-webkit-animation-name: slideIn;-webkit-animation-duration: 0.4s;animation-name: slideIn;animation-duration: 0.4s;font-family: inherit;font-size: 15px;border: 1px solid darkgray;border-radius: 10px;border: 1px solid #c5c5c5;padding: 5px;z-index: 10000;}#sitePrivacyModal .close {color: #000;float: right;font-size: 25px;font-weight: bold;margin-top: -5px;width: 15px;}#sitePrivacyModal .close:hover,#sitePrivacyModal .close:focus {text-decoration: none;cursor: pointer;}
#sitePrivacyModal .privacy-modal-header {color: white;}#sitePrivacyModal .privacy-modal-body {padding: 2px 16px;color:black;}#sitePrivacyModal .privacy-modal-body a {color:blue;}
#sitePrivacyModal .modal-footer {padding: 2px 16px;color: white;}@-webkit-keyframes slideIn {from {bottom: -300px; opacity: 0} to {bottom: 0; opacity: 1}}@keyframes slideIn {from {bottom: -300px; opacity: 0} to {bottom: 0; opacity: 1}}
@-webkit-keyframes fadeIn {from {opacity: 0} to {opacity: 1}}@keyframes fadeIn {from {opacity: 0} to {opacity: 1}}
@media (max-width: 767px){.privacy-modal-content {position: fixed;bottom: 0;width: 50% !important;}}
</style>
<div id="sitePrivacyModal" class="privacy-modal"><div class="privacy-modal-content"><div class="privacy-modal-header"><span class="close" id="privacyAgreed">&times;</span></div><div class="privacy-modal-body">We have made updates to our <a href="/privacy">Privacy Policy</a> to reflect the implementation of the General Data Protection Regulation.</div></div></div>
<script>
var sitePrivacyModal = document.getElementById('sitePrivacyModal');
var privacyAgreed = document.getElementById("privacyAgreed");
var d = new Date();d.setTime(d.getTime() + (31*24*60*60*1000));
var cookieExp = "expires="+ d.toUTCString();
var cookieName = 'qs_privacy_agreed'; 
var cookieValue = 'true';
	
window.onload = function() {
	var dt = new Date();
	var currentDate = Date.parse(dt.getFullYear()+'/'+(dt.getMonth()+1)+'/'+dt.getDate());
	if(currentDate >= Date.parse("2018/6/25")){ //only for 31 days
		sitePrivacyModal.style.display = "none";
	}
	else{
		if (document.cookie.replace(/(?:(?:^|.*;\s*)qs_privacy_agreed\s*\=\s*([^;]*).*$)|^.*$/, "$1") !== "true") {
			sitePrivacyModal.style.display = "block";
		}else{
			sitePrivacyModal.style.display = "none";
		}
		document.cookie = cookieName + "=" + cookieValue + ";" + cookieExp + ";path=/";
	}

}
privacyAgreed.onclick = function() {
	document.cookie = cookieName + "=" + cookieValue + ";" + cookieExp + ";path=/";
	sitePrivacyModal.style.display = "none";
}

</script>
</div>
</footer>            
    </div>
    

                <script src="/cms/js/6694951.js">
</script>
    
                <script src="/cms/js/7197bf6.js">
</script>
    
   
    <script type="text/javascript" lang="javascript">
        document.domain = 'eweek.com';
        var expire5min = (new Date()).getTime() + 120000; // expiration time - 5 min from now
    
</script>

                <script src="/cms/js/ff6e58f.js">
</script>
       

        <script>
        window.twttr  = (function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0],
            t         = window.twttr || {};

          if (d.getElementById(id)) return t;

          js     = d.createElement(s);
          js.id  = id;
          js.src = "https://platform.twitter.com/widgets.js";
          fjs.parentNode.insertBefore(js, fjs);

          t._e    = [];
          t.ready = function(f) {
            t._e.push(f);
          };

          return t;
        }(document, "script", "twitter-wjs"));
    
</script>
    
    
   



    
        
                            <script>
            if (myQSPfm == "des" || myQSPfm == "tab-l" || myQSPfm == "tab-p") {
                document.write("<!-- QS-AD: p1-oop start -->");
                var t = displayDFPTag("p1-oop");
                document.write(t);
                document.write("<!-- QS-AD: p1-oop end -->");
            }
        
</script>
            <script>
        if (myQSPfm == "des") {
            document.write("<!-- QS-AD: p2-oop start -->");
            var t = displayDFPTag("p2-oop");
            document.write(t);
            document.write("<!-- QS-AD: p2-oop end -->");
        }
    
</script>
        <script>
        if (myQSPfm == "des" || myQSPfm == "mob") {
            document.write("<!-- QS-AD: p3-oop start -->");
            var t = displayDFPTag("p3-oop");
            document.write(t);
            document.write("<!-- QS-AD: p3-oop end -->");
        }
    
</script>
  </body>
</html>
