Apache HTTP Web Server users are being urged to update their servers to patch for a series of vulnerabilities in the widely deployed open-source technology.
The Apache HTTP Server (commonly referred to as simply "Apache") is a foundational component of the modern internet and is the most widely used web server in the world today. The new flaws impact multiple versions of Apache ranging from the 2.4.17 release until the 2.4.38 update. The new Apache 2.4.39 milestone was released on April 1, fixing six vulnerabilities in total, three of which are rated as being "important" by the Apache Software Foundation.
"Flaw in Apache HTTP Server 2.4.17 - 2.4.38 allows anyone you allow to write a script (PHP, CGI,..) to gain root," Mark Cox, consulting engineer at Red Hat and VP of Security at the Apache Software Foundation, wrote in a Twitter posting. "Get 2.4.39 *now* especially if you have untrusted script authors or run shared hosting."
Among the three important vulnerabilities patched in the Apache 2.4.39 update is CVE-2019-0211, which is a privilege escalation flaw. The vulnerability was reported to Apache by researcher Charles Fol, a security engineer at Ambionics Security.
"Apache HTTP suffers from a local root privilege escalation vulnerability due to an out-of-bounds array access leading to an arbitrary function call," Fol wrote in an advisory.
The CVE-2019-0211 issue abuses a daily function in Apache known as logrotate, the runs once a day to restet log files. Fol has colloquially dubbed the flaw as CARPE DIEM - CARPE: stands for CVE-2019-0211 Apache Root Privilege Escalation; and DIEM is because the exploit triggers once a day.
CVE-2019-0217 and CVE-2019-0215
Security researcher Simon Kappel is credited by Apache with discovering the CVE-2019-0217 vulnerability which is also rated as being important.
"In Apache HTTP Server 2.4 release 2.4.38 and prior, a race condition in mod_auth_digest when running in a threaded server could allow a user with valid credentials to authenticate using another username, bypassing configured access control restrictions," Apache warned in its advisory.
A race condition is a type of software defect where shared data is accessed by multiple concurrent threads without proper data access protection.
The third critical issue patched in the Apache 2.4.39 update is CVE-2019-0215, which is an SSL access control bypass flaw. The mod_SSL module in Apache is responsible for handling SSL/TLS (Secure Sockets Library/Transport Layer Security) encryption. According to Apache, the CVE-2019-0215 flaw could have potentially enabled an attacker to bypass access control restrictions.
Millions of Web Servers at Risk
According to security firm Rapid7, as of April 3, there are approximately two million Apache web server deployments that are not yet patched. Over half of those instances are running on public cloud and shared hosting providers.
Bob Rudis, Chief Data Scientist at Rapid7, commented that the CVE-2019-0211 issue is particularly worrisome since it can be triggered with a malicious Apache module or via scripts that execute in popular extension like "mod_php,” which enables running of PHP scripts, such as those used by the popular WordPress or Drupal content management systems. He warned that CVE-2019-0211 is especially problematic and prone to exploit in shared hosting providers that run multiple sites under one umbrella Apache process.
While there is a risk from the Apache Web Server flaws for those organizations that have not yet patched, so far there hasn't been much in the way of public detection for active attacks.
"Nothing on the radar yet, though most organizations that have honeypot networks like Rapid7 does, won't see much activity outside of perhaps scanning for version numbers," Rudis told eWEEK. "This is going to be something attackers do on the inside, for example by setting up an account on a vulnerable shared web hosting provider and then launching an attack from within."
Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.